SRCDS Steam group

Team Fortress 2
How can I make non-steam Team Fortress 2 server on windows ?
I use: "C:\tf2\srcds.exe" -console -game tf -hostport 27016 -pingboost 1 -exec server.cfg -nomaster -autoupdate -insecure +map cp_gravelpit
But when I turn on server, it show [Image: 1.gif] and just turn off. When I use: "C:\tf2\srcds.exe" -console -game tf -hostport 27016 -pingboost 1 -exec server.cfg -nomaster -autoupdate -insecure +map ctf_2fort
Then the server show [Image: 3.gif] ! and when I use: "C:\tf2\srcds.exe" -console -game tf -hostport 27016 -pingboost 1 -exec server.cfg -nomaster -autoupdate -insecure
Then it show [Image: 2.gif]
did you try reupdating your tf2 server files? you need to use the _verify function to see if that fixes it within hldsupdatetool
Yes, I do that on every day !
You have to load a map, else it won't run.

add +map <mapnamehere> to the startupline

If you don't have any plugins installed and you get those memory errors, it means that some files are corrupt, rerun the updatetool in order to get it to work. (including -verify_all)
Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)
I've a little problem with hldsupdatetool ! Now when I write:
htdsupdatetool -command update -game tf -dir c:\wormy\tf -verify_all
it downloading and show this [Image: 4.gif] and when I try agin, it shows agin this [Image: 4.gif] what should I do ?
you need to keep running it, it will eventually go. Everyone gets this error. Run it with the verify option. It will eventually update.
Smile i make that server is error free ! Now I done it !
I am new to running a source server, but have been running MOH and COD servers for years. I am having some problems downloading the files for TF2. I have run the hldsupdatetool probably 15 times and will not install the orangebox folder or anything in it. It has downloaded a ton of files in a tf folder and hl2 folder, but nothing in the orangebox folder. I read in another thread that someone made the orangebox folder themselves in the main install directory and then it worked for them, and I tried that but still no luck.

Here is my command line (which I am running via a bat file) for the hldsupdatetool: F:\TF2\hldsupdatetool -command update -game tf -dir f:\TF2 -verify_all

If I open a command window and type the command line in manually, I get "Cannot open blob archive file: CMultiFieldBlob(mem mapped file): File does not exist and failed to create new file".

Any suggestions? What am I missing or doing wrong?

Thanks in advance for any and all help,
Ok, disregard the above post. I found the solution to my problem here:

I searched all day yesterday for a solution but never found it. Two minutes after I post that ^ today, I find it Smile

Forum Jump:

Users browsing this thread: 1 Guest(s)