SRCDS Steam group


"Unable to load Steam Support Library"
#1
Hi. ever since the new engine had been updated due to TF2 going F2P, my gmod server will not load up to the server network. I already did the verify_all command and that didnt work and this is frustrating. here is the screenshot. Specs have been provided along with the server cfg
[Image: srcdsbug.jpg]

Server OS: Windows XP Home Edition SP3
Processor: Intel Pentium 4 Hyperthreading
Ram: 2048MB
Game(s):Garrys Mod
Start Up Command:Using Server Doc C:\sdv1_00\serverdoc.exe C:\srcds\orangebox\srcds.exe -console -game garrysmod +map gm_flatgrass.bsp +maxplayers 10
Admin Mods: Non at the moment.

Config:
hostname "[PGR] Official Build |PHX, Wire, PewPew, GDC|"
sbox_maxwire_thrusters 100
sbox_maxwire_gates 1000
sbox_maxwire_rangers 200
sbox_maxwire_buttons 500
sbox_maxwire_indicators 500
sbox_maxprops 100
sbox_plpldamage 1
sbox_godmode 0
sv_alltalk 1
sbox_maxpewpew 10
sbox_maxvehicles 4
wire_holograms_modelany 1
motdfile evolvemotd.txt
Reply
#2
Have you tried just installing a separate fresh install and seeing if that works? I've seen people have an issue with addons here lately with the new updates.
Game Servers -- CentralFrag.com -- Use promocode "frag" for 15% off every month!
Reply
#3
Yes. and with no addons whatsoever. and it still persists. What I did is uninstalled the server completely. wiped everything our of that directory. then fired up the update tool to reinstall the server. and it still showed up that message
Reply
#4
https://support.steampowered.com/kb_article.php?ref=2198-AGHC-7226

Try checking out this link.
Game Servers -- CentralFrag.com -- Use promocode "frag" for 15% off every month!
Reply
#5
Ports are already forwarded and I added SRCDS and HLDSupdatetool as exceptions. still shows this error. One thing I didnt tell you is that I use AVG antivirus as my AV. does that AV cause any problems with SRCDS?
Reply
#6
If AVG has the firewall built into it, it possibly could yes. Just the standard AV, it shouldn't.

I would say disable any firewalls you possibly could have, Windows and/or any other software and make sure your ports are forwarded correctly.
Game Servers -- CentralFrag.com -- Use promocode "frag" for 15% off every month!
Reply
#7
They are already off And I said before that the ports are already forwarded. It Still persists
Reply
#8
Im still waiting for a reply as this problem is still an issue
Reply
#9
im having the same issues trying to run my CS:S server, did you find a fix?
Reply
#10
No I havent. its most likely a SRCDS issue
Reply
#11
Maybe check your router's Firewall to see if theres any exception errors.

This has to be an isolated problem on your end..
[Image: 1789915.png]

Smile
Reply
#12
I actually did disable the firewall to see if it was that problem. and it infact wasnt
Reply
#13
yeah i have the same problem. no firewall and dmz but problem persists
EDIT: Oops restarted server and its all good
Reply
#14
Someone at the Steam forums said to install Steam on your server machine. (Windows) I did that and it fixed the problem. FYI, I installed Steam but I did not need to log in or create an account. In fact, you don't need Steam running.
Reply
#15
i have had this 1 or times times no i just restarted the box and it was good to go..
-- -- -- -- -- -- -- -- -- -- -- -- --
Better, Faster Cheaper Cloud Hosting
http://www.FragUK.Net
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)