SRCDS Steam group

Memory could not be read error
I am having issues setting up a windows CS Source server. I have done 3 fresh installs on 3 different PC's. 2 with Windows 7 64 bit and one with windows XP Pro will all updates and service packs applied.

On all 3 machines I get the same issue. The server will start and run through one round of play. WHen the server changes levels it crashes. I get the Memory could not be read error along with this in the server window:

[Image: err1.jpg]

There are no mods installed, no firewall and the AV software has been disabled. All 3 were fresh downloads using the hldsupdatetool.exe. Here is the server.cfg file:

// server name
hostname "CS:S Server"

// rcon passsword

// Server password

// server cvars
mp_friendlyfire 1
mp_footsteps 1
mp_autoteambalance 1
mp_autokick 0
mp_flashlight 0
mp_tkpunish 1
mp_forcecamera 0
sv_alltalk 0
sv_pausable 0
sv_cheats 0
sv_consistency 1
sv_allowupload 1
sv_allowdownload 1
sv_maxspeed 320
mp_limitteams 2
mp_hostagepenalty 5
sv_voiceenable 1
mp_allowspectators 1
mp_timelimit 25
mp_chattime 5
sv_timeout 65

// round specific cvars
mp_freezetime 0
mp_roundtime 4
mp_startmoney 800
mp_c4timer 30
mp_fraglimit 0
mp_maxrounds 15
mp_winlimit 8
mp_playerid 0
mp_spawnprotectiontime 5

// bandwidth rates/settings
sv_minrate 0
sv_maxrate 0
decalfrequency 10
sv_maxupdaterate 100
sv_minupdaterate 20

// server logging
log off
sv_logbans 0
sv_logecho 1
sv_logfile 1
sv_log_onefile 0

// operation
sv_lan 1
sv_region 1

// execute ban files
exec banned_user.cfg
exec banned_ip.cfg

Here is the satartup shortcut:
"C:\Program Files\Valve\HLServer\css\srcds.exe" -console -game cstrike -autoupdate +maxplayers 20 +map de_port

There is nothing in the server log files I can see.

It is not a video card issue. 2 are ATI and one is an nVidia. I tried running it it safe mode with networks support and got the same issue.

Any help would be great.

What's the map rotation or mapcycle.txt for the server?
What's in the maplist.txt and mapcycle.txt?
Have you tried running the server with an empty server.cfg?
Have you tried a different map besides de_port such as de_dust2?
Did you specify the -ip and -port in the startup line?

You startup line should look something like this.

For example,
F:\SRCDS\srcds.exe -console -game cstrike -tickrate 33 -ip -port 27015 -maxplayers 10 +map de_dust2

If the server does not crash when changing map, the problem might be the server.cfg. If the server crashes without anything set in the server.cfg, then it must be something else. You can try deleting the InstallRecord.blob file so when you run the updater again, it will go through every file to see if it's there or update it.
Earn Points, get Free Rewards with your Amazon Points!

I made a blank server.cfg with only an rcon password to change levels. That worked good so it is something in the config file. I used the server.cfg creator at cstrike planet to create the above config file. I'll figure out what it was by process of elimination.

Thanks for the help.
I think these values for these commands need to be different. It could have possibly caused the server crash. From my experience running installing and running servers, both shouldn't be set to 0. These are responsible for sending/defining the max/min of data/packets to the client from the server to either download maps/connecting to the server.

sv_minrate 0
sv_maxrate 0
Earn Points, get Free Rewards with your Amazon Points!

I'd love to know the outcome of this. Please report back if changing the rate values Ghost Assassin suggested fixed your problem.

About Me:
I help people who at least try to help themselves. Please use the "Search" button before posting a new topic.
If you post, give us the info we need from the "READ ME FIRST" sticky at the top of each thread!

I'm here to share my experiences to help others. If I'm wrong about something, don't hold it against me, educate me.
I not perfect and try to learn from every failure, yours and mine.
I'll play with it this weekend and report back.

I only setup the server when we have a LAN Party (I dont maintain a public CS Server anymore) so I have not tinkered with it for a few days.

Thanks for the help.
It was the sv_lan and sv_region tags. Removing them the server runs fine.

Forum Jump:

Users browsing this thread: 1 Guest(s)