SRCDS Steam group

CS:GO server requires lobby reservation but is unreserved.
Server OS: Windows 2008R2 x64
Processor: i5-2500 4x3.3GHz
Ram: 16Gb 1333MHz
Game(s): CS:GO
Start Up Command: srcds -game csgo -console -usercon +game_type 0 +game_mode 1 +mapgroup mg_bomb +map de_dust +net_public_adr -port 27016 -verify_all -maxplayers 32 -tickrate 100 +fps_max 200
Admin Mods: None

Bandwidth: 50MB Down /4MB Up
Router: Wired Gigabit connection through Linksys WRT320N
Local IP of Server:
External IP:
SRCDS Port binding: 27016
Port Forwarding Screen Shot: Rather not post a screenshot due to security issues, but ports have been tested and are open.
using the Typical Home Network: [Server] --> [Router] --> [Modem] --> [Internet]

server.cfg Wrote:hostname "Counter-Strike: Global Offensive Dedicated Server"
sv_password "" //Only set this if you intend to have a private server!
hostname "Classic Competitive mg_bomb"
mp_freezetime 5 //The amount of time players are frozen to buy items
mp_join_grace_time 15 //The amount of time players can join teams after a round has started
mp_match_end_restart 0 // Defines whether a map should be restarted after a game has ended
sv_cheats 0 //This should always be set, so you know it's not on
sv_lan 0 //This should always be set, so you know it's not on
//**The bot commands below are mostly default with the exception of
bot_difficulty 2
bot_chatter "off"
bot_join_after_player 1
bot_quota 10
bot_quota_mode "fill"
//**The following commands manage kicks and bans
exec banned_user.cfg
exec banned_ip.cfg

Im having connection issues to my server, getting the following from the client.
Client Console Wrote:] connect
Connecting to public( ...
5958.322: Sending UDP connect to public IP
Server using 'public' lobbies, requiring pw no, lobby id 0
RememberIPAddressForLobby: lobby 0 from address
Grace request retry for unreserved server...
Retrying public( ...
5958.332: Sending UDP connect to public IP
Server using 'public' lobbies, requiring pw no, lobby id 0
RememberIPAddressForLobby: lobby 0 from address
Server approved grace request...
Retrying connection to, server requires lobby reservation but is unreserved.
Received game details information from
[MM] Sending reservation request to
[MM] Sending reservation request to
Its just stuck there.

The server console goes out of hybernation when trying to connect, loads the server.cfg and then stops doing anyting. After a while it goes back into hybernation.

The weird thing, that at some point I have been able to connect externaly and localy. And at the moment it seems pretty random when it works or not. I have played against random people joining my server, and against friends.

The problem is that I have no clue what is causing the issue atm. For I am not able to join the server, you can try the server is online at the moment.

I have tried:
sv_allow_lobby_connect_only 0
Adjusting the mapgroups
different gamemodes
A clean install
removing autoexec.cfg and server.cfg

Before the update from Aug 15th I was able to connect through LAN, but not externaly. Now both are giving the above problem. I am now running a clean install.
i experienced the same problem a couple of times this evening, although i was never able to connect to the server without encountering the problem first. My solution was to bring up the console in-game after trying to connect via the server browser. When the lines displayed in your post were displyed i typed connect 172.6......ETC, which took me in to the server.

My server was running on the same pc as the game client.

Hope this helps in idetifying the actual problem.
I have the same issue. It seems that I can connect every time no problem if someone is already in my server, if the server is empty, it is very difficult if not impossible to get in it. If I take the +net_public_adr out of the command, then I can get in no problem, but only people on my lan can get in.

With the +net_public_adr the internet can get on my server, but from my lan, I can only connect to the game if someone is already in it.
I have the same exact problem. Is it possible the game was designed this way to prevent permanent achievement farming? I guess killing bots doesn't count. I can only join the server outside my lan or when someone else is in the server. Any info on why this is happening would be great. I would really like to be able to try and populate my own server.


Try adding +ip it worked for me when I was running the server on my gaming rig.
Hi everyone, here is how I finally fixed this problem.

It seems server starts up in "hibernate" mode so I can not connect.

To fix I had to make it come out of hibernate using bots.

I had to put this in server.cfg:

// for some reason i must do this
bot_quota_mode normal
bot_add ct
bot_add t
bot_add ct
bot_add t

After this I can connect to my server from lan (it's sv_lan 0)

Forum Jump:

Users browsing this thread: 1 Guest(s)