SRCDS Steam group

updating srcds
I have a quick question, it's probably something silly but I can't seem to update my srcds correctly. I was wondering if I was doing something wrong with my command.

I installed my srcds in the SRCDS folder below


I run the below command in a batch file to update my server.
C:\SRCDS\hldsupdatetool -command update -game tf -dir C:\SRCDS

Is something fishy there? Because when it runs the command the cmd window pops up and it says checking bootstrapper, updating install...
checking / installing team fortress 2 materials version 25
checking / installing 'base source shared materials version 8
and a few more lines after that then drops closes.

Everything was working great pre-last nights patch when and said my server was out of date. I ran my update script and now it doesn't it's out of date anymore but when I attempt to join i get some funky line
"Invalid Steam key size."
when I attempt to connect client side. I looked up the error and it said it had to do with the server not being up to date...
Ideas..? I'm new to the whole srcds so I'm thinking it's something goofy I missed.
Try this:

C:\SRCDS\hldsupdatetool -command update -game tf -dir C:\SRCDS -verify_all
Well... now I'm getting another error with the verify_all command. It says cannot delete file c:\srcds/orangebox\tf\bin\server.dll error 5.

I used the exact line you gave me. I checked the file permissions and read only was unchecked so in theory it should be able to write... or rather delete the file...

I did a couple forum search on cannot delete file server.dll but nothing was showing up.

Any ideas...?

Oh.. and the server is not running... I made sure the process was not there in task manager.
delete all the bin folders yourself and run the updater again.
Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)
The steam ID chopping was caused by the plugin.
Disable all your plugins and try running the server.
~ Mooga ...w00t? - on Twitter
[Image: 76561197965445574.png]
Please do not PM me for server related help
fqdn Wrote:if you've seen the any of the matrix movies, a game server is not all that different. it runs a version of the game that handles the entire world for each client connected. that's the 2 sentence explanation.
Also you can add -autoupdate to your startup line and it will automatically update as the server starts.
[Image: b_350x20_C002748-004880-FFFFFF-000000.png]
autoupdate does not work in windows only linux, which is gay that it doesn't work in windows
[Image: 3386928252.png]
Thanks for all the advice guys..

-Mooga There is/was no plugins installed on the server, thanks for the suggestion though.

-Drocona I wasn't able to delete the bin folder that contains the server.dll until I downloaded a program called MoveOnBoot. Somehow the server.dll was being used despite no active processes running. I access my computer using remote desktop so I was unable to boot into safe mode to delete the file manually. The program MoveOnBoot allows you to choose a file / or folder to delete before windows services are activated. That took care of the crazy un-deletable server.dll. I ran the update script again after deleting the server.dll and attempted to start the server and received yet another error. I pretty much gave up at that point and deleted the entire orangebox folder and re ran the update and since then everything is working A+.

I wish I could have figured out the root of the problem. I'm thinking something must have happened the first time I tried to update the server and somehow that update corrupted the tf files.

I appreciate all the help and fast responses.
- Paul
Hmmm, i thought i was in the linux section... o well, valve needs to get their ass in gear to get that working though... they got the -pidfile working with windows though.
[Image: b_350x20_C002748-004880-FFFFFF-000000.png]

Forum Jump:

Users browsing this thread: 1 Guest(s)