SRCDS Steam group

New TF2 update broke autoupdate (again)?

I'm patching the srcds_run exchanging the row



cd ..; updatesingle; cd orangebox;

Which worked like charm until yesterday after the update. It looks like they put the wrong folder in the commandline to steam:

if test "$GAME" = "tf"; then

Which makes it look for files ABOVE the folder where steam is located.

earlier the command was issued like so:

./steam -command update -game "tf" -dir .

Anyone else noticed this? is there a simple fix? Have they silently moved the location of steam binary for fresh installs?
I analyzed the srcds_run and it seems like they try to fix the problem now, but they miss out on where the steam binary should be located for l4d and tf2.

If you change the section that sets the STEAM variable when parsing the -autoupdate switch to this:

                        if test "$GAME" = "tf"; then
                        RESTART="yes" ;;

It works for me. So the file still needs patching, but not the one used earlier..

I filed a bug report to valve, maybe they'll fix it. Some day.
Actually I got a reply in the steam forums claiming that its supposed to work like this.

If you copy the steam binary into your orangebox folder it will work without a patch.

I can't say I think this is the most elegant solution with different copies of steam binary in the filesystem, and I'm not sure how update of the steam binary is supposed to work.

Anyhow I tried to do restore srcds_run to it's original state, copied the steam binary into the orangebox folder, and now it works.

Forum Jump:

Users browsing this thread: 1 Guest(s)