SRCDS Steam group

Installation problem - after 3 days of trying.
I have to be missing something simple here.
I've tried this on win2000, win xp, and now windows vista, and I am about to pull my hair out.

I am trying to install Day of Defeat: Source dedicated server.

*on all 3 operating systems*
I have downloaded and installed srcds via the link on this webpage.
It installed great, as reccomended i used c:\srcds
I then ran (in console) hldsupdatetool -command update -game "dods" -dir C:\srcds

This appeared to work, on a couple occasions it said winsock error and connection closed by peer, but executing the command again finished the job. (I personally witnessed it get to 100%)

I believe all is good so far.
Now I have c:\srcds containing:

Quote: Directory of C:\srcds

11/26/2008 04:17 AM <DIR> .
11/26/2008 04:17 AM <DIR> ..
11/26/2008 05:47 AM 615,596 ClientRegistry.blob
11/26/2008 04:17 AM <DIR> hl2
11/26/2008 04:17 AM 1,082,616 HldsUpdateTool.exe
11/26/2008 04:17 AM 23 HldsUpdateTool_35.mst
04/07/2005 01:27 PM 3,429 hldsupdatetool_readme.txt
11/26/2008 04:15 AM 1,733 INSTALL.LOG
11/26/2008 05:48 AM 1,395 InstallRecord.blob
11/26/2008 05:53 AM <DIR> orangebox
07/26/2002 05:02 PM 153,088 UNWISE.EXE
7 File(s) 1,857,880 bytes
4 Dir(s) 47,446,192,128 bytes free

and an orangebox subdirectory containing:

Quote: Directory of C:\srcds\orangebox

11/26/2008 05:53 AM <DIR> .
11/26/2008 05:53 AM <DIR> ..
11/26/2008 05:48 AM <DIR> bin
11/26/2008 05:47 AM <DIR> dod
11/26/2008 05:48 AM <DIR> hl2
11/26/2008 05:48 AM 600 hlds_steamgames.vdf
11/26/2008 04:17 AM <DIR> platform
11/26/2008 05:48 AM 132,344 srcds.exe
2 File(s) 132,944 bytes
6 Dir(s) 47,446,192,128 bytes free

Great! I thought, there's srcds.exe, just what I need!

Now here's where the trouble comes in:

The file does nothing, not in console, not executed, not with a shortcut, not with the bash command mentioned on this site.

The most direct way to launch a gameserver from what I can tell is creating a shortcut saying this:

c:\srcds\orangebox\srcds.exe -console -game dods +map dod_kalt -maxplayers 16 -autoupdate

Right? okay, so I made the shortcut and nothing happens.
Confused, I type the entire string in a command prompt:

Quote:C:\srcds\orangebox>c:\srcds\orangebox\srcds.exe -console -game dods +map dod_kalt -maxplayers 16 -autoupdate


Still nothing!

So then (only tried this on XP as it was obvious it is not the correct way to do it) I use Steam to install "source dedicated server"
After a while it finishes, and I run it only to find counterstrike: source and half life dethmatch to be in the games drop down list. Bummer I think to myself, but I think the hldsupdatetool may be able to get the dod files added to the list!
So I again run:
hldsupdatetool -command update -game "dods" -dir Z:\

(The directory was in C:\program files\steam\steamapps\<username>\source dedicated server but because command prompt will not allow the spaces, I mapped a network drive to that folder to Z: so I would be able to run it in command)
It seemed to work! it was re-downloading the dods files and finished.
Now I launched the program (I tried in steam, console, and later using the shortcut mentioned above)
Somewhat success! the GUI worked, and sure enough Day Of Defeat Source was in the list!
but, the map was not changable from de_dust! and when I clicked run (thinking I could change the map within the game using rcon) it simply crashed and that was the end of it.

Running it from console gave the same blank nothing responce as previous installs.

So sorry if I missed something simple.
Try -game dod in the server commandline.
Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)
Drocona Wrote:Try -game dod in the server commandline.

Thanks, that fixed it.

Stupid valve for calling the game dods for install and dod for run.

Forum Jump:

Users browsing this thread: 1 Guest(s)