SRCDS Steam group


100% CPU Usage
#1
One of my srcds servers has been having a really bad problem lately with 100% CPU usage. The mod its running is Zombie Master, and even with sourcemod/metamod disabled, cpu still spikes to 100% on occasion.

Server Specs:
Dual Core Dual Processor Intel Xeon 3Ghz (8 Virtual Cores)
120GB SATA II drive
4GB Ram
Windows 2003 Server Standard
100Mbit connection on a OC48 network at a Datacenter

Each server runs on its own core. srcds fps booster is also running to increase the system timer.

Any idea how i could stop this? None of the other servers reach 100% cpu usage, they go to around 60% to 80% max. This particular server lags a whole lot most of the time and on occasion has massive lag spikes (that coincide with 100% cpu usage).

Here is the command line i have on the server:

-console -game zombie_master -secure -autoupdate +map zm_crocodile_v4 +log on +maxplayers 16 +ip 209.44.122.36 +port 27015 +exec server2.cfg -tickrate 33 +fps_max 600 -nocrashdialog
[Image: wow_button.gif]
Reply
#2
Zombie mod is pretty hard on a server. I seen you say (8 Virtual Cores)
If you're running them as a virtual server that would most likely be the reason.
Reply
#3
There's no virtual server, its just one installation of the OS. But each server is running on its own virtual core.

By virtual core i mean hyperthreading.

2 CPU's
Each CPU has 2 cores

Hyperthreading is enabled on each CPU, so that means there are:

4 Virtual Cores per CPU x 2 CPU's = 8 Virtual Cores.

There are 4 physical cores though.

I know that ZM is hard on windows servers, but the other windows servers i've seen don't suffer from as much lag as mine does. I dont know if its because the windows build is crap, i haven't heard any problems with the linux build but i can't switch to linux (hosting some servers that only have windows builds).
[Image: wow_button.gif]
Reply
#4
You are running the older model CPU's. You are also running HyperThreading and SRCDS has never ran good with hyperthreading CPU's.
Derek Denholm, CEO, XFactorServers, INC.
XFactorServers: Game Server Hosting Solutions
Follow Us http://www.Twitter.com/XFactorServers
Reply
#5
yes, there should be an option in your bios to disable hyperthreading. like derek said, it works like crap with srcds.
Reply
#6
Eek.

Ok than.

Thanks for the help Big Grin

The model of CPU i'm running is Intel® Xeon® Processor 5050
[Image: wow_button.gif]
Reply
#7
I had better luck running on a P4 with hyperthreading enabled then with it disabled...
~ Mooga ...w00t? - SRCDS.com on Twitter
[Image: 76561197965445574.png]
Please do not PM me for server related help
fqdn Wrote:if you've seen the any of the matrix movies, a game server is not all that different. it runs a version of the game that handles the entire world for each client connected. that's the 2 sentence explanation.
Reply
#8
I did some research and on hlds mailing list, people there also suggested turning it off because srcds doesnt like it.

So what do i do? Turn it off or leave it on?

It's somewhat complicated for me, since i have to physically do the bios modification myself at the datacenter.
[Image: wow_button.gif]
Reply
#9
You can leave it on, just don't use the virtual cores.

I do the same with my Hypertheading Pentium 4, I only use 1 core, not the virtual, then all is fine.
Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)

http://forums.srcds.com/viewtopic/5114
Reply
#10
Mooga Wrote:I had better luck running on a P4 with hyperthreading enabled then with it disabled...

all it does (when running a single instance of srcds) is increase the amount of context switching -- which is bad for performance. i suspect there are other things in play. i have never heard of a situation where hyperthreading improved performance for a single instance of srcds, and techincally it doesn't make sense.

srcds is not multithreaded, a single instance of it cannot make use of more than a single CPU (or logical CPU in this case) at once.
Reply


Forum Jump:


Users browsing this thread: 5 Guest(s)