SRCDS Steam group

Unable to connect to remote server
hello people!!!

im brazilian and you were the last place i could ask for some help!!!

plz help me fellass!!

my friend creates a server and enables rcon!!!

I enter the server and write in the console :

rcon_password *****
(then i write) rcon say oh my GOD
and shows the message below
"Unable to connect to remote server (SERVER IP)"

pla help me my friends!!!!!

is the server your friend created behind a router?
[Image: userbar_wow.jpg]
starting 9/24/2006 if your problem has been solved please edit your first post and add [solved] to the begining of the title. Thanks.
#3 is

what should i do???

thx for the attention!!
Most likely you haven't forwarded the sufficent ports for rcon access, check my post here for a list of ports you need to forward (and a description of their functions). For rcon you should forward port 27015 (TCP) btw.
May the Source be with you...

Want to know which ports to forward on your router for a Source DS? Click here!
I'm mainly replying to this, because I was having the same problem, and couldn't find the answer on google... if the server is behind a router, for some reason the counter-strike client will try to connect to the server's internal address ex; instead of the external (public)

So your command line would look like this

./srcds_run -console -game cstrike +map de_dust2 +maxplayers 14 -autoupdate -ip -port 27015-tickrate 100
not -ip but +ip

and like stated in the two posts above,

most likely, the rcon isn't working because either, there are ports that need to be forwarded, or the server ip wasnt specified somewhere.
you can always add


to the server.cfg if you are having problems with starting the server with the +ip switch
United Strike Marine Corps
USMC-CO| θ (theta)

I am having the same problem. I have opened port 21705 (TCP), but it still does not work.

I want to try the +ip method in the command line, but I am issued with a dynamic IP address from my ISP. Would it be possible to use my domain name instead of the ip?

e.g. +ip


Hi every one.
I have a CSS dedicated server behind firewall on my PC in work. And each time i tried to use rcon command from home i did get the same message "Unable to connect to remote server (SERVER IP)".
Ive instaled SRCDS on my home computer and tried to rcon from work to home and it worked. So i Instaled a software firewall on my home PC and tried to block all UDP incoming packets but the rcon command still worked from work to home. so i decided to block TCP port. And guess what ... The rcon from work to home stoped working...

So the solution on rcon problem "Unable to connect to remote server (SERVER IP)" is:

YOU NEED TO FORWARD UDP AND TCP port 27015 to make rcon work..

I hope this will help
if u have any questions just send me a message

Hey all!

I have the same problem with unable to connect. I just have a slightly different problem. One of my buddies (admin) can use rcon from another country, while my error is the same as everybody else above.

I have tried disabling the firewall on my router, as well as the built in firewall in xp pro. No luck.

So if ano´ther can log on and use rcon from another country (he created the server) then what can you guys suggest might be the problem?

I have putty access (not as root) to create new server.cfg´s and all, so I have the rcon passwrod as well :-)
Is the server at your house? his house? if its in your house behind your network are you using your LAN ip to connect to rcon? are you able to conenct to the server from outside the game using a program such as hlsw?
[Image: userbar_wow.jpg]
starting 9/24/2006 if your problem has been solved please edit your first post and add [solved] to the begining of the title. Thanks.
the server is on the backbone of our ISP, so we are both connecting from the internet...
I have not tried hlsw, but I´ll google it immidiately... :-)

when u configure the rcon do u use the correct IP and PORT ??
Hmm, I have not configured any port or ip on rcon setup in server cfg... should I???
I thought the rcon binded to the server and all with rcon password included in server.cfg...

this is the only line I have in my autoexec.cfg:
// Set the rcon password
rcon_password (password)
In some cases you ahve to type rcon_address <IPaddressofserverhere> in the console of the client first before you can connect to the RCon.
Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)

Forum Jump:

Users browsing this thread: 1 Guest(s)