SRCDS Steam group

HLDS Update Issues since 6-10-2008
Alright, first off, I apologize is this is a poorly chosen forum for this one. Suggestions for cross-posting welcome.

For background, I administer and host 3 dedicated servers all on the same physical machine. 1 DOD:S server, and 2 different TF2 servers. We used to have a CS:S server, but I was asked to shut it down a few months back. Formerly, the DOD and one of the TF2 servers lived in the same c:\hl2server\ directory, with the second TF2 in a different C:\ipaddresshere\ directory. I've been doing this for over a year now, and while I'm not perfect, I ain't completely clueless either. Server is Windows 2k3.

About a week ago, Valve released Version 30 of the hldsupdatetool. Along with a TF2 patch. And some of M$'s updates came out the same day (It must have been Tuesday). I ran the Windows updates while I backed up the server files. So I ran the normal updating script. It gave me the ever popular 10054 Winsock error that we all know and love. I retried with -verify_all, at which point I get this:

0.00% this\file\here
0.00% that\file\there
Could not open file c:\ipaddress\hl2\materials\models\barnacle\roots.v mt

So, I figure "Fine then. This happens sometime. Just delete the file and retry with -verify_all." Right? Wrong. That file, doesn't exist. There's two files in the barnacle directory, and neither of them happen to be roots.vmt. Try to delete the barnacle directory, and it throws an error that the folder is not empty so it can't remove. I can rename the folder, and move the folder anywhere on that logical drive, but I can't move it off nor delete it.

Moving the barnacle folder into a junk folder somewhere on C: doesn't help, as these errors just loop.

Next day:
Annoyed, I sit down and try this again. hldsdatetool proceeds to update itself (again) to Version 31. "Yay!" I think. Except it does the same thing.

Now, to date, I've run Checkdisk multiple times, my RAID array is functioning just fine, I've tried installing a fresh copy into new folders (only to get the same problem), I've even tried installing to an entirely different physical server using a freshly downloaded from the web site version of the hldsupdatetool (and got the same two problems in sequence). Done the virus check stuff, tried defragging, yada yada yada.

Anyone? I'm kinda out of ideas at this point.
1) This is not a HLDS issue (HLDS = Half Life Dedicated Server). This is a HLDSupdateTool problem... which is VERY different. (So I'm moving it to the SRCDS area)
2) If you ran a search, I actually encountered this problem several days ago and posted the problem and the fix. Searching roots.vmt (the file with the error) should find you this thread

Hope this helps! And please search before posting Smile
~ Mooga ...w00t? - on Twitter
[Image: 76561197965445574.png]
Please do not PM me for server related help
fqdn Wrote:if you've seen the any of the matrix movies, a game server is not all that different. it runs a version of the game that handles the entire world for each client connected. that's the 2 sentence explanation.
Thank you for moving it. And sorry about the extra thread creation.

As I had said, I tried removing the barnacle folder (which won't actually delete, but I was able to move it elsewhere), and then went to rerun the update, but I almost always either get a run-time error with HLDSUpdatetool, or I get the 10054 Winsock Error on srcds.exe

I'm half tempted to blame Microsoft's recent updates last week, as there were several I ran right before this happened.

Forum Jump:

Users browsing this thread: 1 Guest(s)