SRCDS Steam group

Post: #1TF2 server, Segmentation fault during starting
Who can help me with to run my own little tf2 server?

I have started today with making one, but for a reason i can't figure out it won't start properly:

root@tank [/steam/tf2]# ./srcds_run -console -game tf -port 27015 +map cp_well +maxplayers 24 -secure
Auto detecting CPU
Using SSE2 Optimised binary.
Server will auto-restart if there is a crash.

Console initialized.
./srcds_run: line 344: 9684 Segmentation fault (core dumped) $HL_CMD
Add "-debug" to the ./srcds_run command line to generate a debug.log to help with solving this problem
Tue Jun 3 20:31:17 UCT 2008: Server restart in 10 seconds
Tue Jun 3 20:31:20 UCT 2008: Server Quit

This line seems to be the trouble: ./srcds_run: line 344: 9684 Segmentation fault (core dumped) $HL_CMD

When i turn on -debug, there isn't much info in the logging:

CRASH: Tue Jun 3 14:54:13 UCT 2008
Start Line: ./srcds_i686 -game tf -hostport 27015 +maxplayers 12 -secure +map cp_well -pidfile /steam/tf2/ -debug
End of Source crash report

What did i do to try to resolve it myself:

./steam -command update -game tf -dir /steam/tf2/ (tf2 dir updating)
./steam -command update -game tf -dir /steam/tf2/ -verify_all (tf2 dir file check)

I have also search the almighty google, but the error gives few hits, and not much info. The suggestions that i found where to make sure the processor supports SSE, but i have a modern processor: Intel® Xeon® CPU E5320 @ 1.86GHz

The OS is CentOS 5.1 64bit, on a dual quadcore dell 2950, Libaries are up2date according to yum, and according to /cat/proc/cpuinfo my kernel/cpu is including SSE and SSE2

Any help to resolve this would be much appreciated

(Sorry for my English spelling)
Have a look at this:
Also what Distro are you using?
~ trewq
Sorry didnt read first post properly still have a look at the link
~ trewq
I have read the topic before, and i am thinking it's the glibc thats older on my machine. I am running a 2.5 version. I will try to see if i can update glibc, but there aren't newer packages in yum for CentOS 5.1

Forum Jump:

Users browsing this thread: 1 Guest(s)