SRCDS Steam group

Mani Admin Plugin...again
Hey, sorry to start another Topic, but from what I can gather, this problem hasnt been fully addressed. Ive read several topics in the Archived Section of this Forum and also several apparantly active threads.

Ive been trying for about 3 days now to get Mani Admin working. Ive tried getting it work on CS:S as part of my listen server (steamapps/<user>/counter-strike source) and as part of my Dedicate Server (steamapps/<user>/source dedicated server). Ive the following versions of Mani Admin to different degrees of success;

v1.2 BETA - Crashes both Listen and Dedicated server when a player joins regardless of loading as a VSP or as a MetaMod plugin.

v1.1 0s/0zh - Wont load with error below
] plugin_load "../cstrike/addons/mani_admin_plugin"
Loading Mani Admin Plugin 2005 V1.1.0zh,

Loaded playerinfomanager interface at 2252BF98
Loaded engine interface at 2036D60C
Loaded events manager interface at 203C15E0
Loaded filesystem interface at 015E5B4C
Loaded helpers interface at 205337F4
Loaded networkstringtable interface at 204F507C
Loaded enginetrace interface
Loaded random stream interface at 2036A3F8
Loaded IServerGameEnts interface at 2251CB48
Loaded effects interface at 22511784
Loaded sounds interface at 2036D8AC
Loaded cvar interface at 2036699C
Falling back to ServerGameDLL003
Falling back to ServerGameDLL003
Failed to load servergamedll interface
Failed to load plugin "../cstrike/addons/mani_admin_plugin"
Unable to load plugin "../cstrike/addons/mani_admin_plugin"

MetaMod:Source loads fine on both servers. When using Mani Admin v1.2 as a MetaMod plugin on the Dedicate Server it appears to load fine from the console and all features appear to work. However, upon entering CS:S and joining the server, the Dedicated Server crashes with a Memory Read Error. When using the Listen Server, whilst creating the game it crashes to desktop with the same Memory Read Error.

No matter what I do, I cant seem to get Mani Admin to function what so ever. There must be something im doing wrong, I just dont know what. Ive been over at least half a dozen DIFFERENT tutorials several times each without any success. Any and all help is greatly appreciated.
The 1.1's won't word for sure, try 1.2o instead of s.
Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)
Thanks worked perfectly with the suggested distribution. I cant believe it was that simple and that I couldnt find this anywhere else Smile

Forum Jump:

Users browsing this thread: 1 Guest(s)