SRCDS Steam group

Server dosen't load

I'm trying to get a server working on a LAN. I've followed the Linux installation procedure but when I start the server on LAN or WAN using this command line : ./srcds_run -debug -game "cstrike" -console +ip +map de_dust2
here the result :
Auto detecting CPU
Using SSE2 Optimised binary.
Enabling debug mode
Server will auto-restart if there is a crash.

Console initialized.
Game.dll loaded for "Counter-Strike: Source"
maxplayers set to 32
Network: IP, mode MP, dedicated Yes, ports 27015 SV / 27005 CL
Executing dedicated server config file
Error: Material "sprites/bubble" : proxy "AnimatedTexture" not found!
Section [Scenes]: 0 resources total 0 bytes, 0.00 % of limit (2.10 MB)
net.cpp (960) : Assertion Failed: 0 == iRet && iValLen == sizeof( iVal ) && cSendBufSize <= iVal
net.cpp (968) : Assertion Failed: 0 == iRet && iValLen == sizeof( iVal ) && cRecvBufSize <= iVal
Could not establish connection to Steam servers.

He stuck there I never get the statement : World triggered "Round_Start"
I can't connect on the server.

I'm running my server on a Ubuntu 7.10 Gusty

the server version is:
Checking/Installing 'Counter-Strike Source Shared Content' version 68
Checking/Installing 'Base Source Shared Models' version 4
Checking/Installing 'Base Source Shared Sounds' version 4
Checking/Installing 'Base Source Shared Materials' version 8
Checking/Installing 'Source Dedicated Server Linux' version 90

Here my server.cfg
Quote:// server.cfg

// For Counter-Stirke copy to cstrike directory

// For Counter-Strike: Source copy to cstrike/cfg directory

// hostname - Set the name of your server

hostname "Counter-Strike Server"

// rcon_password - This allows you to control your server remotely, things like changing maps, kick/ban clients, etc.

rcon_password "********"

// mp_buytime <seconds> - The amount of time to allow purchasing weapons/equipment on round start

mp_buytime 0.45

// mp_startmoney <money> - Specify how much money players start off with

mp_startmoney 800

// mp_c4timer <seconds> - How long before the c4 explodes

mp_c4timer 45

// mp_timelimit <minutes> - How long each map should be played before switching levels

mp_timelimit 25

// mp_freezetime <seconds> - How long players are unable to move during round starts

mp_freezetime 5
mp_friendlyfire 1
mp_flashlight 1
MP_tkpunish 0
mp_hostagepenalty 0

// sv_cheats <0/1> - Whether to allow game cheat commands to be used by clients. 0 = off | 1 = on

sv_cheats 0

// sv_maxrate <1000-25000> - The maximum bandwidth rate the server is allowed to transmit to clients

sv_maxrate 10000

// sv_pausable <0/1> - Whether to allow clients to pause the server. 0 = off | 1 = on

sv_pausable 0

// sv_contact <email/web address> Contact email for server admin

sv_contact ""

// sv_region <1-7> - The region of the world to report the server in.

sv_region 0

I've created a rule in IPTables for the server on port 27015

I ran a portscan using nmap and the port 27015 is open.

I can't find the debug.log where is he supposed to be?

Anyone can help me with that?
try opening ports 27000 through 27030

debug.log should be in cstrike or the parent dir (try putting -debug after all the other commands)

also try running a command at the server after it says failed to contact steam servers (like stats or status)
I tried to put the -debug at the and and i still doesn't find the debug.log and
I've opened the port UDP 27000 to 27030
iptables -t filter -A INPUT -p udp --dport 27000:27030 -j ACCEPT

When i try to type a command in the console nothing append I can't issue command to the server.
debug.log won't exist until there are debug messages. If the server is working correctly there won't be a debug.log.

I suggest turning off iptables completely just to rule it out. If it still doesn't work after iptables is off then you know it is something else too.

Forum Jump:

Users browsing this thread: 1 Guest(s)