SRCDS Steam group

sv_downloaldURL - client issue - Missing map disconnecting
OK, I'm going bonkers here. I've tried to setup our Source server to use the fast download which looks pretty easy. I've followed tutorials including: this one

Long and short: It works for most people but not for some (including myself). Many people have commented on how much faster all of the maps load now and clearly the fast download is working, but on my computer when I try to connect to the server (if I don't have the map) I see all of our custom sounds & admin skins transfer but when it gets to the Map it says: Missing map maps/gg_aim_ag_texture_jungle-l.bsp, disconnecting

in my server.cnf:

sv_allowupload 1
sv_allowdownload 1
sv_downloadurl ""

under my web server I have: which if I enter it in the browser prompts for download (and downloads fast).

Originally I mirrored my cstrike folder up, then later, after it didn't work, used a utility to bzip and send up my files to the site.

My web server is Linux based so mime types should not be an issue.

The part that drives me nuts is THERE IS NO HIT ON THE WEBSERVER. Since it's on one of my servers I can watch the logs in real time. I can see other people hitting the server but I can not see my client even try to request the file (so no get request, and no 404 - file not found error either).

In the CS:S console it says:
Counter-Strike: Source
Map: gg_aim_ag_texture_jungle-l
Players: 10 / 25
Build 3264
Server Number 95
No pure server whitelist. sv_pure = 0
Missing map maps/gg_aim_ag_texture_jungle-l.bsp, disconnecting

If I set sv_downloadURL "" in my server config I can trickle download the maps, but if the URL is in there it says Missing Map.

I've seen this problem on servers others than mine too. If I don't have the map and they have the fast download enabled I get the same error message.

other info:
If I download the .bsp file and drop it in my local maps folder it works fine
I have removed Steam & All settings from my machine and redownloaded everything. Had to even setup my display name, & sprays but I still have the same behavior as before.

I wanted to mention it last so it doesn't become a scapegoat but I am running Windows Vista. I've talked to other people who have run CS:S under Vista without any issue downloading the maps so I doubt that Vista by itself it the only cause, but may be part of the problem

I have tried setting the steam and hl.exe programs to run in XP SP2 compatibility modes (on the hunch of a friend) but still no go.

I know I can download the maps to my machine manually (especially since I play mostly on my server) but 1) I want to be able to play on other well setup servers and 2) I want to make sure anyone who comes over to our server can play easily.

Hopefully as you can see I have searched high and low (through this forum, other forums, & with google) for over 4 hours solid and found nothing. I've tried to include everything I've done so far but my head is bloody from beating it across the wall so forgive me if I've missed something.

Finally, I appologize if this is the wrong section on the forum. There seemed like so many places it could fit, it'd start here and move it somewhere else if more appropiate.

Thanks for any assistance you can offer!


[Image: b_560x95.png]
Interesting problem and it looks like you've checked everything.

Only things that come to mind...

Linux http server, case sensitive--make sure the case of the bz2 and file on the server are the same--but may not be an issue if others are downloading it and you can't

Do you put your FTP client in binary mode if you are uploading the files via ftp?

Only two issues I can think of that may be causing problems.
Manage your redirects/fast downloads with one click! SourceRSC and HL1RSC
Need a free web based game server hosting panel? Check out UGCC.
Thanks for the suggestions. I've tried checked the case sensitivity twice and then checked again.

The original files (unbziped) were transferred with binary on (I was aware of the potential issues) and as were the first round of bzipped files. The second round was put there by an automated tool (SourceRSC rocks) but I'm sure they've been transfered properly as everyone else in our mini-clan has no issues (although I'm the only one currently running Vista).

Thanks for the ideas and if anyone else has anything I'm all ears.


Masher Wrote:Interesting problem and it looks like you've checked everything.

Linux http server, case sensitive

Do you put your FTP client in binary mode ?
Update: I have also opened a Ticket with Valve support to see what assistance they can provide. If I get a solution from them I will be sure to post it (in the mean time I'm still happy to take other ideas).
They probably won't even respond or say something like "we don't give server support"

I'm thinking but I'm not sure what it could be since you covered pretty much everything......
Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)
Ok I had the same problem. Simply put "net_maxfilesize 64" on both the servers config AND in your console on the computer you are connecting from.
Drocona Wrote:They probably won't even respond or say something like "we don't give server support"

I'm thinking but I'm not sure what it could be since you covered pretty much everything......

That's exactly what they said. 5 months later I'm still looking for a solution. I can only play servers for which I have the maps loaded or don't use fast download Sad

(net_maxfilesize 64 didn't help -- but thanks)
set the net_maxfilesize to 99 that what i have on my server when it works...
[Image: 3386928252.png]
assmunk Wrote:set the net_maxfilesize to 99 that what i have on my server when it works...

I tried that on my client and it does not help. It's not specific to our server server since I can't pull maps from any one else's server either.

Thanks for the tip though.
I have discovered the problem has something to do with my Windows profile. I logged in as another user and was able to download maps just fine (under the same steam account). Now I'm double really baffled Sad
This is just a guess...whatever map you can't download....go to where your game directory is at and look in the maps folder. Look if you have that map that keeps disconnecting you because you are missing that map. If you find that map in the maps folder....delete it. Sometimes when sv_downloadurl isn't download a part of the map...and the size would be small like 6kb. Just delete it from your maps folder and try reconnecting to the server with that map running and see if you can download it. The problem is...that if you have downloaded the map before but only part of it....when you join the server that has that map gets all messed up cuz it's confused since there's already a map downloaded but it's not the actual size of the map.

About net_maxfilesize, it just controls what the max file that the server should load....if it's set lowered...certain maps wouldn't load.
Earn Points, get Free Rewards with your Amazon Points!

Ghost Assassin Wrote:This is just a guess...whatever map you can't download....go to where your game directory is at and look in the maps folder.

Thanks for the suggestion. I checked that too. There are no map files in the directory. And it happens with ALL fast download servers and all items (maps, sounds, skins, etc). If I don't have the sounds I can still join but of course without the map I'm SOL.

Right now I've found a workaround where I use the RunAs command to run CS & Steam as another administrative user and everything works fine. I've checked every permission I can find (both file & registry) and everything's set to everyone full control so I'm baffled. I've opened another ticket with steam support requesting a senior tech review the issue. They've not responded making me wonder if they have no senior techs or they're just blowing me off. I'll keep you posted with their response if I get one. They've had one business day, I'll give them a couple and see what they say. At least last time they told me to suck it up and reformat so we'll see what they respond this time.
Well, if your server provider can't get the could always use another site to host a sv_downloadurl. Try using this's free...

Just make an account and download their client program to upload the files. I would first download sourceRSC, compress the files, and upload them to the site. This is just a recommendation if your frustrated and impaitent, or your last option if your server provider can't do anything right.
Earn Points, get Free Rewards with your Amazon Points!

Was there ever found a solution for the problem ? :-)
Hi guys just incase you didnt know. If you have set the server up as per normal to allow the map downloads make sure that your website (the site you download the files from) is set to allow mimi types .bsp and .nav files.

so in your mimi types you need:

.bsp application/x-httpd-php-source
.nav application/x-httpd-php-source

This will allow your website to recognise the map files

Forum Jump:

Users browsing this thread: 1 Guest(s)