SRCDS Steam group

Server is fine on LAN but not on internet!
Hey I am trying to run a Counter-Strike Source dedicated server and can't seem to get it on the internet! It works fine on the LAN, my brother and I can easily play but if I want any friends on I'm screwed. I have forwarded all the necessary ports. Here is what I am using as a command:

./srcds_run -console -game cstrike +map de_dust2 -maxplayers 16 +ip -port 26015 -autoupdate

I assigned the ip address that the router assigned to the server.

Sorry but I just don't know what do try, so Thank you in advance!
[Image: 201998095.png]
sv_lan 0 ?

// server name
hostname " | Lanthrax Server"

// rcon passsword
rcon_password "" // rcon disabled

// server cvars
mp_friendlyfire 0
mp_footsteps 1
mp_autoteambalance 1
mp_dynamicpricing 0
mp_autokick 0
mp_flashlight 0
mp_tkpunish 1
mp_forcecamera 0
sv_alltalk 0
sv_pausable 0
sv_cheats 0
sv_consistency 1
sv_allowupload 1
sv_allowdownload 1
sv_maxspeed 320
mp_limitteams 2
mp_hostagepenalty 5
sv_voiceenable 1
mp_allowspectators 1
mp_timelimit 25
mp_chattime 10
sv_timeout 65

// round specific cvars
mp_freezetime 6
mp_roundtime 5
mp_startmoney 800
mp_c4timer 45
mp_fraglimit 0
mp_maxrounds 0
mp_winlimit 0
mp_playerid 0
mp_spawnprotectiontime 5

// bandwidth rates/settings
sv_minrate 0
sv_maxrate 0
decalfrequency 10
sv_maxupdaterate 60
sv_minupdaterate 10

// server logging
log off
sv_logbans 0
sv_logecho 1
sv_logfile 1
sv_log_onefile 0

// operation
sv_lan 0
sv_region 0

// execute ban files
exec banned_user.cfg
exec banned_ip.cfg
[Image: 201998095.png]
Triple check the router config and make sure there aren't any firewalls that block stuff.
Also some routers are incompatible for hosting on the internet, in this case you could try new firmware or get a more professional router instead of the low value standard home router.
Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)
Well sure enough there was some firewall thing turned on that blocks WAN requests. This computer lady that comes to my house ALWAYS turns it on(sort of a mini battle between me and her), but it is still not working! I just don't understand. Here is my router name and firmware.

Router: Linksys WRT54G
Firmware Version: v4.21.1, Nov. 6, 2006

I don't think there should be any problems though because I have run a server on here before.
[Image: 201998095.png]
By the way this is what it looks like when i run

[SRCDS@localhost ~]$ cd srcds[SRCDS@localhost srcds]$ ./srcds_run -console -game cstrike +map de_dust2 -maxplayers 16 -autoupdate
Auto detecting CPU
Using SSE2 Optimised binary.
Auto-restarting the server on crash
Updating server using Steam.
Checking bootstrapper version ...
Updating Installation
Checking/Installing 'Counter-Strike Source Shared Content' version 67

Checking/Installing 'Base Source Shared Models' version 4

Checking/Installing 'Base Source Shared Sounds' version 4

Checking/Installing 'Base Source Shared Materials' version 8

Checking/Installing 'Source Dedicated Server Linux' version 89

HLDS installation up to date

Console initialized.
Game.dll loaded for "Counter-Strike: Source"
Loading Mani Admin Plugin 2005 V1.1.0zh,

Loaded playerinfomanager interface at 0x4b31d68
Loaded engine interface at 0x124ac60
Loaded events manager interface at 0x121ac20
Loaded filesystem interface at 0x538d84
Loaded helpers interface at 0x12475e0
Loaded networkstringtable interface at 0x1224e40
Loaded enginetrace interface
Loaded random stream interface at 0x122bc40
Loaded IServerGameEnts interface at 0x4b21154
Loaded effects interface at 0x4b09e30
Loaded sounds interface at 0x124e5d8
Loaded cvar interface at 0x1218054
Falling back to ServerGameDLL003
Falling back to ServerGameDLL003
Failed to load servergamedll interface
Failed to load plugin "../cstrike/addons/mani_admin_plugin"
maxplayers set to 16
Unknown command "mani_reverse_admin_flags"
Unknown command "mani_reverse_immunity_flags"
Network: IP, mode MP, dedicated Yes, ports 27015 SV / 27005 CL
Executing dedicated server config file
Incorrect price blob version! Update your server!
ERROR: mp_dynamicpricing set to 1 but couldn't download the price list!
Error: Material "sprites/bubble" : proxy "AnimatedTexture" not found!
Section [Scenes]: 0 resources total 0 bytes, 0.00 % of limit (2.10 MB)
net.cpp (960) : Assertion Failed: 0 == iRet && iValLen == sizeof( iVal ) && cSendBufSize <= iVal
net.cpp (968) : Assertion Failed: 0 == iRet && iValLen == sizeof( iVal ) && cRecvBufSize <= iVal
couldn't exec banned_user.cfg
couldn't exec banned_ip.cfg
Adding master server
Adding master server
Connection to Steam servers successful (SU).
VAC secure mode is activated.
[Image: 201998095.png]
Everything there is fine (including errors - as they have been there for ages).

Only thing is, Mani Admin doesn't seem to load. Either because you dont have the file there or the .vdf isnt pointing to the right file. Either way, you should really run Mani Admin under Metamod: Source now as standalone doesn't work very well anymore.

Forum Jump:

Users browsing this thread: 1 Guest(s)