SRCDS Steam group

for those who cant find SRCDS.exe
Im on vista and this worked for me

when i ran the update the connecting would be reset my peer so i had to run it about 5 times for it to completely install

i used:

hldsupdatetool.exe -command update -game "tf" -dir C:\srcds

and just kept doing that till it had all the files

i had to run the command about 5 times for it to complete

[Image: th_srcdsdoneqs.jpg]
(click for full view)

hope this helps
Yeah, I had to do the exact same thing. Stupid Vista
ok for counter strike source its

hldsupdatetool.exe -command update -game "cstrike" -dir C:\srcds

or is it

hldsupdatetool.exe -command update -game "counter-strike source" -dir C:\srcds

my command prompt closes in like 2 seconds when i run the commands

EDIT: ok well hldsupdatetool -command update -game "Counter-Strike Source" -dir C:\srcds seems to be working...altho i got 'no installation record' error 4 times then it started a download?

if thats normal in Vista then ok cool..
Yep... I'll tell you what to do...

1. Open Notepad and type this in...

cd srcds
hldsupdatetool.exe -command update -game "Counter-Strike Source" -dir C:\srcds

Then go to... file -> save as -> update.bat (file type "All Files".) Save it to desktop or somewhere easily accessable.

2. Go to the place where you saved update.bat, and double click it. It should bring up Command Prompt (Cmd.exe) and start downloading something. After about 5 minutes it will close. What has happened is it has just veryfied that it needs updating, updates the 'bootstrap version' , installs Counter-Strike Source Shared Content then closes.

3. Double click Update.bat again to continue downloading where you left off... It will check the Bootstapper version then continue to download the second section... Next I think it is The Source Models... Again, after the Source Models have downloaded, it will close.

4. Continue to double click update.bat 5 times in total (3 more times after step 3.) If you want to know if you've downloaded them all, run 'update.bat' and it should say...

Checking bootstrapper version . . .
Updating Installation

Checking/Installing 'Counter-Strike Source Shared Content' version 67

Checking/Installing 'Base Source Shared Models' version 4

Checking/Installing 'Base Source Shared Sounds' version 4

Checking/Installing 'Base Source Shared Materials' version 8

Checking/Installing 'Source Dedicated Server' version 92 (hard to see this one come up, it flashes for about .5 of a second then Cmd.exe will close.)
Turbo! Wrote:altho i got 'no installation record' error 4 times then it started a download?

It's not an error, it's a check for InstallRecord.blob file in the specified folder.

when it's done checking it installs the files or continues where it stopped last time.
Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)

Forum Jump:

Users browsing this thread: 1 Guest(s)