SRCDS Steam group

Server not responding - Nat router
i know that there is alot of posts regarding this subject but even though i follow all advice i cant get it working:

its the typical problem that the server is not open for the public. I can join it myself but other people cant.

My router is an Zyxel 2602r-61 and im pretty sure its a nat router.
I have port forwarded, i have no firewalls enabled and ofcourse sv_lan 0 is on. Ive tried to disable nat in my router admin but then the whole network goes down.

This is how it looks like my router admin:
Dont mind the danish text, look at the pictures.

its really frustrating.. ive been trying to troubleshoot for a week now but i give up now and it would be really cool if you guys have the answer.

c:\srcds\srcds.exe -console -game cstrike +map de_dust -maxplayers 16 -autoupdate

This is my startup line
and this is my server.cfg:

Quote:IP //Your external IP
Port 27015 //Opens up port 27015

// server name
hostname "[CreAtivé*e*Sports]"

// rcon passsword

// server cvars
mp_friendlyfire 0
mp_footsteps 1
mp_autoteambalance 1
mp_autokick 0
mp_flashlight 0
mp_tkpunish 1
mp_forcecamera 0
sv_alltalk 0
sv_pausable 0
sv_cheats 0
sv_consistency 1
sv_allowupload 1
sv_allowdownload 1
sv_maxspeed 320
mp_limitteams 2
mp_hostagepenalty 5
sv_voiceenable 1
mp_allowspectators 1
mp_timelimit 25
mp_chattime 10
sv_timeout 65

// round specific cvars
mp_freezetime 6
mp_roundtime 5
mp_startmoney 800
mp_c4timer 45
mp_fraglimit 0
mp_maxrounds 0
mp_winlimit 0
mp_playerid 0
mp_spawnprotectiontime 5

// bandwidth rates/settings
sv_minrate 4000
sv_maxrate 8000
decalfrequency 60
sv_maxupdaterate 60
sv_minupdaterate 10

// server logging
log off
sv_logbans 0
sv_logecho 1
sv_logfile 1
sv_log_onefile 0

// operation
sv_lan 0
sv_region 255
no one of you have an idead of what the problems could be?
did you try
did you forward ports corectly?

try my guide:

triple check ports forward, firewalls that clock it or any anti-virus utility that might cause problems.
if all fails.. nothing you can do but buy a new router or buy a server-switch setup.
Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)
I tried portforward .com.. and used the guide that my providere gave me.. and yes i have triple checked it..
someone said that it helps to turn of nat or something is bad about nat..
is nat the problem or is it something else?

I dont have any firewall or anti virus utility.. and my router is the one my providere sent

and thx for help mate
the whole router is the problem lol, there's only a VERY small amount of routers that work correct, mostly these re very expnsive. If you are sure the ports are forwarded correctly and it still doesn't work, try the DMZ option in the router.

That's the last thing you can try...
Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)
Hey madsolsen .. Whats your MSN? I got same routher, same internet provider and it got it working. I'm from Denmark as well ..
k.. ty.. my msn is and email:
would be cool if we could get it working..
and thx drocona...
i dont think i can run dmz mode with this router..
we tried alot of things but it still doesent work..
port forwarding and server files are excactly like bonsaiheros files and port forwarding.. and its very frustrating why it doesent work Sad
Here are the ports that need to be forwarded, from the guide:

UDP 1200 (Friends Network)
UDP 27000 to 27015 (Gameport)
UDP 27020
TCP 27030 to 27039
TCP 27015 (SRCDS Rcon port)

Take note of the TCP and UDP. If these are not correct in your setup, then it will not work at all. Pretty simple.

Almost ALL routers that support port forwarding should be able to accept these settings. Even if you have to add the ranges (27000-27015, 27030-27039) as individual ports, that will work the same as a range. The best router I've seen for home use is the Linksys WRT-54g series.. great port forward support, stable, cheap, etc. and they support Linux based 3rd party firmwares, which have lots of great settings for us gamers.

Personally I have an old Pentium II Dell with dual NICs running pfSense as my router. Infinite configuration on that, so I have no problem tweaking whatever settings need to be tweaked to get stuff like this to run. If you don't feel comfortable running something like that (it's a bit ..uh.. involved), I would recommend a Linksys router.

That said, I have managed to get SRCDS running successfully behind Linksys, D-Link, Belkin, Trendnet, and several other brands of router, so, it's not impossible. Just make sure you follow the guide ( ) and correctly forward your ports, and you should be alright.

I would NOT recommend DMZ, as this will completely open which ever computer you have SRCDS running on to attack, as it will be completely exposed to the Internet with no firewall protection whatsoever... so... unless you have a dedicated machine running SRCDS and know how to lock it down tight, try to exhaust all of your port forwarding options before attempting DMZ.
did you open the port on your router ?

try to start you server and check it at Link
[Image: 598429334.png]

need help ? ask someone else !
Please do not raise old, dead threads from the dead. If you need similar help, please feel free to post your own thread with your question. Remember to read the required READ ME FIRST thread for the area in which you are posting.

Thread Locked.
~ Mooga ...w00t? - on Twitter
[Image: 76561197965445574.png]
Please do not PM me for server related help
fqdn Wrote:if you've seen the any of the matrix movies, a game server is not all that different. it runs a version of the game that handles the entire world for each client connected. that's the 2 sentence explanation.

Forum Jump:

Users browsing this thread: 1 Guest(s)