SRCDS Steam group

Server stops initializing on "VAC secure mode is activated"
hi all, i have been trying to set up a css dedicated server.  i have got all the files downloaded, created a .cfg file, and created a batch file.
<<c:\srcds\srcds.exe -console -game cstrike +map de_dust2 -maxplayers 14 -port 27015>>.  i have forwarded the ports to my server's internal ip as well. I am behind a router [netgear WGR614 v 4] these ports here

when i start up my server it ends with VAC secure mode activated.  however, i dont get the "Round_Trip" message that others have been referring to.  im not sure that is the problem, but it seemed like a good idea to post that just in case.

my problem is that no one is able to connect to my server via internet.  also, i cannot find my server on the search engine.  yes, there have been previous posts on this topic however i have been unable to find a clear cut answer as to why.  if anyone could help me with this issue that would be great. thank you
never mind about the "round trip" i get that now after turning on logging lol

but...people still cant connect. ive forwarded ports, made my internal ip static, and added my ip to the top of my server.cfg.

no one can connect, doesnt pick it up, someone please help me
try binding the server to the internal ip (+ip or
If that doesnt work either check your ports again, check any firewall or virusscanner running so it doesnt get blocked.
Make sure you search for your external IP on gametiger and inside the game (
try add it to your favorites (note that when you connect from the same LAN it ONLY shows up as a LAN server, you can however add it to your favorites with the external IP.)
If nothing works use the DMZ option in the router and try again.
Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)
thanks for the help, i have partially solved the problem Smile i changed my start up command line to c:\srcds\srcds.exe -console -game cstrike -autoupdate +maxplayers 14 +map de_dust2 -tickrate 100 +fps_max 600 +exec server.cfg +ip -port 27015

and now in the console it reads network: ip instead of my internal ip

however now i get the error message : could not establish connection to steam servers.  i suspect this is a port problem, will look into it.  but if its not, and there is an alternate fix, any help would be great

UPDATE: i tried placing the server on the dmz, and i still get the "could not establish connection to steam servers" error.
If you are behind a router you should always bind your internal IP adress. This way the server will listen to stuff on the IP you set. Since you are behind a router your machine doesnt have the external IP so it cannot listen to it.
Try with DMZ and bind the internal ip adress (+ip It should work that way.

EDIT: Just a quick note, if you havent already set sv_lan to 0 somewhere in the server.cfg or startupline.
Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)
ok, i did what you said and it sort of works now.  i can see my server in the 'internet' tab in steam, and when i search for my external ip in xfire, my server comes up.  however, others still cannot connect.  i have given them my external ip, and still they are unable to.

is this a step in the right direction? or is it another problem all together?

update: this seems odd, but it comes up as <my externak ip> with the port :27016 at the end.  i thought that it was supposed to be 27015, and im not specifying this other port in any start up command line, or in my config.

what i have tried so far: forwarding ports 1200, 27000-27015, 27020-27039 , binding my internal ip to my start up line, putting my server on DMZ, disabling my firewall, STEAM GUI [with this i can see it on the internet tab, but still no dice for others] i missing something random? lol?

Forum Jump:

Users browsing this thread: 1 Guest(s)