SRCDS Steam group

what does this memory error mean?
"The instruction at 0x00932723 referenced memory at 0x1091009c. The memory could not be read. "

Only happens when I run servers for Half Life Source mods. Only happens when I run the dedicated standalone server. Doesn't happen for any other server I run or when I run Half Life listen server. I ran two ram checks/tests and there no problems with the ram. Already tried google. Anyone else ever seen this error and solved the problem? Any advice appreciated. Thanks!
Turn off error reporting service.
[Image: banner.gif]

Hollanda Wrote:Turn off error reporting service.

Yea I had all that turned off except for major errors. I guess I will go turn off the major errors and see what happens, although that is just a work around and not really fixing the problem. I also found this interesting webpage that makes it sound like Java JRE is my problem because it is conflicting with one of the windows upates/hotfixes:
sir_fragsalot Wrote:although that is just a work around and not really fixing the problem.

It's quite standard to turn error reporting off on gameservers. It has no real function actually (on gameservers), cause problems are mostly not windows related.
[Image: banner.gif]

Ok, here are all the steps I have just done to try to solve the problem. I will run server again tonight and after 12 hours I will follow up with you again. The worrisome thing so far is that now serveral people have told me they get this error when they do just common internet browsing. But more gamers than browsers have told me they got it with their games too. So that is why I am doing all the steps below.

Run Regedit from run box. Look at the following locations in the registry and change the

values from 0 to 1:

hkey_local_machine-system-currentcontrolset-control-session manager-memory management

and look for

DisablePagingExecutive waarde = 1
LargeSystemCache = 1

You can always go back and put the values back to zero if you are skeptical about this one.


Doubt this next one will do anything for you in regards to this specific memory problem, but you might as well try it to rule it out. I did, and it showed no errors.

Go to Run box again and run sfc /scannow. Make sure you have your Windows CD in the cdrom. This checks all your system files to make sure they are not corruopt. You will probably have to hit the Retry button about 40 times because it stops and asks you each
time it finds a file that has a problem or doesn't match the original and is not stored on your computer. You can read more about scan fc here:


If you have installed Java or bought a computer with Jave on it, you should try this one. I honestly don't know what this one could do with me running a server, but you might as well try it. They actually had a screenshot of the exact error I was getting, so that's why I tried it. And, of course, I never noticed this problem before I installed Java. I did Solution #2 on this webpage:


And this next tip is a work-around, but I know for sure it works. Most of the people who have complained about this error would not even have known about it had they turned off their error reporting system.

So go into Control Panel > System > Advanced tab > and

select button Error Reporting. Then uncheck everything except the first one that says Disable Error Reporting. Out of sight out of mind for those who had the error when they were internet browsing. For me, my server might still crash, but we shall see soon enough.


Ok, this step makes me a little concerned about the guy's knowledge who suggested it. And I really don't think its my problem, even though I did upgrade from 512mb to 1 gig of ram. But alot of ram guru will tell you to do something similar to this when you get a memory error after you upgraded ram. And it certainly won't hurt you to try it. Note
though that for me I could not make the setting 2 times bigger as this guy suggests to do. I could only set the maximum for 17000mb because that is all Windows would let me do, but that is still pretty big. I also believe you are supposed to delete your old
pagesys file before you do any of these steps, but he does not say that below.

The instructions:

Try recreating the virtual memory.

For XP system...
1. Right-click on My Computer and select Properties.
2. Click the Advanced Tab and select Settings under the Perfomance Options.
3. Click on the Advanced Tab and select Change under Virtual Memory.
4. Click No Paging File and clisk Set.
5. Click OK, OK, OK and tell the system to restart.
6. Let the system reboot...It will be slower than usual.
7. Right-click on My Computer and select Properties.
8. Click the Advanced Tab and select Settings under the Perfomance Options.
9. Click on the Advanced Tab and select Change under Virtual Memory.
10. Click Custom Size and set the Initial Size to (1.5 times your Physical Memory.)
11. Set Maximum to (2 times your Physical Memory.)
12. Click OK, OK, OK. No reboot required.

This problem stems from system images. When a manufacturer creates an image and then changes the memory but does not update the image, memory errors can occur. This can even happen when you upgrade your own system memory. Always recreate the Virtual memory after modifying physical memory. It should prevent these types of errors.
I suppose you host from a dedicated server? I also suppose you host under windows (2003?), if so you just have to disable error reporting from the service manager (windows services). Not able to login to a server right now but it's something like: start >> programs >> admin tasks >> services.

Also I can recommend serverchecker, that does the trick for you.

All you need to do to creat a good windows 2003 gameserver for srcds are these steps + allways have WMP running (for higher fps).
[Image: banner.gif]

I already had error reporting turned off, but Microsoft said this was a "critical error," which is why it was reported to me. So I really should try to fix it. However, I did turn off the reporting of Critical errors. The server should still crash though unless this error is fixed, but we will know for sure tomorrow Smile

And this does only happen when I run a Source dedicated server. It does not happen with any other server I run including non-Valve games. It does not happen when I run a listen server either. The thing is that I only run the Source servers full time, so the error might also happen with the other servers too if they were up at the right time. That's why I need to get this error fixed instead of just turning its warning off.

What is this "WMP" you are talking about?

Thanks for the advice.
WMP = windows media player

Read my previous post and follow up, DISABLE error reporting (install serverchecker, this will do the trick + restart server when they crash).
[Image: banner.gif]

Turning off the error reporting did not work, and constantly restarting a server that constantly crashes is not a solution I'm afraid Sad   Thank you very much for trying to help me, but I need to try to move on to another solution now.

Here are the popup warnings I found in the windows event viewer tonight after the memory error occurred again and the server crashed again.

1) Application popup: srcds.exe - Entry Point Not Found : The procedure entry point IsLogActive could not be located in the dynamic link library tier0_s.dll.

2) Application popup: srcds.exe - Entry Point Not Found : The procedure entry point IsLogActive could not be located in the dynamic link library tier0_s.dll.

then 2 hours later I get the memory error:

3) Application popup: srcds.exe - Application Error : The instruction at "0x009e2723" referenced memory at "0x109100a8". The memory could not be "read".
Click on OK to terminate the program
Did you install serverchecker? If no DO so.

How many crashes do you have in what time?

What mods are you running?
[Image: banner.gif]

this is as simple as a broken plugin, I get those all the time when I test my plugins..

for the islogactive try turning off dynamic weapon pricing (add +mp_dynamicpricing 0 to your startupline
Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)
I wanted to let you guys know that I deleted that client registry.blob thing and then ran hlupdate tool again. I don't know what that could have done to fix the problem, but the server has not crashed one time in 24 hours . . .. meaning that I have not gotten that memory error again either. Because it never stayed up longer then 3 hours without giving me the error and then crashing, I guess the problem has been solved.

Bah!!!! The problem came back yet again. Another problem is the pop up won't close. It just sits there and waits for you to hit "OK" to close all the while my server hangs. Anyway, I dloaded Serverchecker, and I've got it setup and running. Hopefully serverchecker will work with this error, but I suspect it won't because the popup still comes even with Windows Error Reporting turned off.

Through constant research in Google, I see that the Google error complaints start in late 2005 right around August and come after the update went from 40 to 41. I've also noticed that earlier this year on this forum another guy posted about this error believing it was because of Mani plugin. I don't think so, especially because I'm not using any plugins . . . . at least none that don't come with the Source games I'm running.
I deleted everything, downloaded the updatetool again and re-downloaded the server config files. The updatetool was newer than the one I had and the "platform" folder in the server directory was 680kb smaller in size than what I had. I ran the server all night last night and did not have one crash. So maybe I'll get lucky and the new install fixed it.

Forum Jump:

Users browsing this thread: 1 Guest(s)