SRCDS Steam group

Segmentation fault, is it my kernel? (2.6.12)
My full 34 person zombie server crashed and wouldn't boot back up. When I run steam it says

Checking bootstrapper version...
Segmentation fault!

And that's it. I even reinstalled everything elsewhere, same crap. Do I have to update my kernel?
it's 2.6.12 FC4

I hope not, last time I tried I broke a bunch of stuff.

Here's what shows up when I connect to the server:

Connecting to xxxxxxx
Connected to xxxxxxx

Counter-Strike: Source
Map: de_dust
Players: 1 / 34
Build 2916
Server Number 1
SetConVar: No such cvar ( mani_nextmap set to de_aztec), skipping
SetConVar: No such cvar ( mani_tickrate set to 33), skipping
SetConVar: No such cvar ( mani_reserve_slots set to 1), skipping
SetConVar: No such cvar ( zombie_enabled set to 1), skipping
Bad CRC for scripts/weapon_elite.ctx
Bad CRC for scripts/weapon_fiveseven.ctx
Bad CRC for scripts/weapon_p228.ctx
Server is enforcing consistency for this file:

Host_Error: Server is enforcing file consistency for scripts/weapon_p228.ctx

I think that gets fixed when I update steam. However, I can't update steam because of the segmentation crap.

well thanks for the help
Ok what exactly is the problem, the server is running right?
Also, you run steam on Linux? howd you do that.
Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)
Update the server
[Image: banner.gif]

The server is not running, it abruptly crashed on Saturday morning.

The problem is I can't relaunch ./steam For that matter, I can't launch steam anywhere. I redownloaded it and everything, no good.

My exact kernel is 2.6.12-1.1398_FC4smp

[root@m13 srcds_3]# cd /home
[root@m13 srcds_3]# mkdir srcds_3
[root@m13 srcds_3]# cd srcds_3
[root@m13 srcds_3]# wget
[root@m13 srcds_3]# chmod +x hldsupdatetool.bin
[root@m13 srcds_3]# ./hldsupdatetool.bin


Enter 'yes' to accept this agreement, 'no' to decline: yes
extracting steam.tar.Z...done
[root@m13 srcds_3]# ./steam
Checking bootstrapper version ...
Segmentation fault
[root@m13 srcds_3]#
hmm, kerneldhouldnt cause a segmentation fault
seems to be a steam binary error
Linux IsiX 64 Generic Desktop ValHalla x86_64
Intel Core 2 Duo T8400 4Gb Ram 40G SSD Intel
[Image: b_460x42_C000000-454234-696149-FFFFFF-FFF468-FFF468.png]
DoD 31 Comunity DoD 31 Spanish Comunity
Erste SS Panzer Grendier Division [DOD Clan]
I have exactly the same problem as draxxas on my linux server. we've been running a successful tf2 dedicated server for some time and this past weekend's updates has got us in the same situation.

We can't run ./steam without "segmentaton fault" and the -autoupdate parameter has been disabled in order to at least (although not ideal) lets the players get on the server with map changes. The console is issuing the obligatory "MasterRequestRestart" message and needs the next update. This is a catch 22 situation.

Some threads tell me to remove the InstallRecord.blob file and try it again. waste of time! same old error "segmentation fault"

Someone help before I tear my hair out. We are on day 4 of the search for a solution.

thanks :/
delete /root/.steam
[Image: b_350x20_C002748-004880-FFFFFF-000000.png]
reinstall everything... make sure you back up any extra files you put on. if you use sourcemod, make sure you are using 1.2.2... 1.2.1 caused me to have segfaults.
FC4 is very old, maybe it is no longer supported? this could cause a segfault, if there was some update that made the server incompatible with such old systems... but I don't actually know, it's only a guess. (Linux Kernel HOWTO!)
Do not ask technical questions via PM!
I had a minor success earlier... I managed to get steam to run without the segmentation fault as the root user. I tested it on a temp server setup and it updated no problem. That rules out a fundamental fault in the application.

After changing the permissions of all the updated files to the gameserver user, I still got the annoying segmentation error in the console as the user. It seems to be some kind of file permissions issue but I can't quite put my finger on it yet. Every single file is chowned to the user. Oh - and despite the root user getting the updates successfully, the console still says it needs to update to the latest version. weird.

I removed the /root/.steam folder as suggested but this made no difference (but thanks for pointing out yet another blob file for me.) maybe it just needs a base server reboot to kick it back into gear. will let you all know soon.

Still, its a mini success Smile

maybe it's not /root/.steam you need to remove but the .steam directory in your users home... (Linux Kernel HOWTO!)
Do not ask technical questions via PM!
.steam in the user home folder was non existent when I checked. I have advanced view enabled to show hidden folders such as these and it's just not there. There was a .steam folder in /root/ which was removed but I think that was created during diagnostic tests last night.

HOWEVER: I got it all working -yipee. For some stange reason, the fact that the .steam folder wasn't present still generated the seg fault. When I manually created the folder and ran the steam executable, the clientregistry.blob file was written to the folder and all is well with the world again Big Grin

Thanks guys, without your advice this would not have happened.

Summary: if ./steam -command update...... gives "segmentation fault" then go to /home/user/.steam and delete the file ClientRegistry.blob. DO NOT delete the .steam folder. If the folder doesn't exist, create it! simples (although not so obvious to us noobs.)

Hi, I have try your recommendation but it is still giving me segmentation fault.

I deleted the /home/user/.steam/ClientRegistry.blob

Deleted the InstallRecord.blob

then do a ./steam -command update -game "Counter-Strike Source" -verify_all -dir .

I still get the segmentation fault.

Any advice? Thanks!
you'll get a new one today, see one topic down!

Forum Jump:

Users browsing this thread: 1 Guest(s)