SRCDS Steam group

help! Cannot Get the srcds to work off my external IP
well... I've just updated it and I can run the programme using my internal ip ( I've port forwarded my router and my external IP is So when I used the command

srcds.exe -console -game cstrike +ip +map de_dust -max players 8 -autoupdate... The server connects but i am the only one who can play it... If I try to use the code
srcds.exe -console -game cstrike +ip +map de_dust -maxplayers 8 -autoupdate I get an error message saying "Couldn't allocate the dedicated servers UDP Port." I have a static IP and if this makes any difference my DNS is My friend has had no trouble doing it this way, however, he has managed to successfully overcome this. Please help.

-thanks in advance
Make sure the following ports are forwarded properly on your router:

Dedicated Server

* UDP 27015 and 27020 (Default HLDS, SRCDS and HLTV ports)
* TCP 27015 (SRCDS Rcon port)

Failing that, try this:​fY2F0cz0wJnBfcHY9JnBfY3Y9JnBfc2VhcmNoX3R5cGU9YW5zd2Vycy5zZWFyY2hfbmwmcF9wYWdlPTE​mcF9zZWFyY2hfdGV4dD1wb3J0cw**&p_li=&p_topview=1
Right this is what I've done...

I'm using a belkin router and I've opened ports...
27020-27039 - TCP
27015 - 27015 - TCP
1200 - 1200 UDP
27000 - 27015 UDP

I open up my .BAT file which runs the command

cd \srcds
srcds.exe -console -game cstrike +ip +map de_dust -maxplayers 8 -autoupdate -debug

And the error comes up "cannont allocate the dedicated UDP Port."

However, If I change the IP to my LAN IP, then the server connects fine, mani-admin runs etc, but only I can connect, no-one else can connect to my WAN IP. In my Server.CFG I have added the line

port 27015

And yet still no-one can connect to the IP And yet when I run my .BAT file, it connects to the Master Server ok when I used my LAN. please help me!
Try putting yourself in DMZ in your router and see if that fixes it.
Sorry for the noob question, but how I do that ^^
What's the model number of your Belkin router?
Hmmmm I did have it at one time, I think it's one of # F5D5230-4
# F5D5231-4 those...
You can download your manual here:

Page #44 walks you through setting your computer up in DMZ.

Let me know how it goes Wink
DM thnx very very very much for your help but all along it was damn Zone Alarm... Thnx so much for your help your too kind Big Grin
I have a little problem, sounds pretty much like freddukes, my portforwards should be fine, server settings + startup target should be fine, everything should be fine, but nobody are able to join my server, only I can. I'm using my internal ip at the target line, because an error pops up, when I try to use the external ip. Before did my server works great, everyone could join, and i've used my internal ip? That doesn't make sence. I have tried to type in "hostip external ip" in server console, and still same problem. Really don't know what to do. Please help!

(Zyxel Router P-2602HW-D1A)
27015-27025 - Internal IP - Active.

But i don't think that it's the ports there is the problem, think that it is the IP adress problem. Looking forward to getting helped ;D
Please do not raise old, dead threads from the dead. If you need similar help, please feel free to post your own thread with your question. Remember to read the required READ ME FIRST thread for the area in which you are posting.

Thread Locked.

Forum Jump:

Users browsing this thread: 1 Guest(s)