SRCDS Steam group

Mulitple servers, having a problem
Hi, I've been running a server on Fedora linux for quite some time now, it runs flawlessly. Recently I've wanted to also include a second private server on the same machine, but I'm having trouble.

I've changed the port in the command line, to that one runs on port 27015 and one on 27020. When I run them independantly they both run fine, but when they are both up at the same time I have problems. Whichever server came up first works fine, I can connect and play no problems. The second one that's started is a problem though. I can't connect to it, and it doesn't show up in the LAN servers in Steam like the first one does. However, that server works fine when started first and/or by itself, so I'm at a loss. Any ideas on what I'm doing wrong?

I made seperate folders for both servers so it's easier to keep track of addons and maps etc, I've also tried running both servers from the same folder to no avail. Hope someone can help. Thanks.

Some stats I guess might help:
Fedora Core
Using screen to switch between server consoles
Running servers as root user (I've heard this is bad, but don't know if it is really a problem.)
2.8Ghz P4
1.5GB Ram
Asus mobo and other stats, it's solid though, no hardware problems

Hmm, something that may help, when the 2nd server starts it gives me this "RCON Server bind failed (Address already in use)".

Maybe I need to change the RCON port somehow?

Hope you can help.
give them difrent ports.. or start from same server ? ..

like 27015 27016
They are on different ports, one 27015 and 27020 try setting rcon_port 27020 in the second server, see if that works, also try changing the steam port -steamport or -sport i belive.
[Image: userbar_wow.jpg]
starting 9/24/2006 if your problem has been solved please edit your first post and add [solved] to the begining of the title. Thanks.
Hi there

I have the same problem. -.-

Starting 1. server with:

./srcds_run -console -port 27015 -game cstrike +exec server.cfg +map de_dust +maxplayers 12 &

Works all fine.

Staring 2. server with:

./srcds_run -console -port 27115 -rcon_port 271120 -steamport 271125 -game cstrike +exec server2.cfg +map de_dust +maxplayers 12 &

This message appear:

Quote:RCON Server bind failed (Address already in use)

I've tried it with -sport and without this parameter.

Running the server under debian stable.

Thanks for help Smile

BTW: Why there is no clear dokumentation about srcds?

is a joke or? Oo


netstat -a when 1 server is running:

udp        0      0 *:27015                 *:*
udp        0      0 *:27020                 *:*

I think the 27020 is the rcon port, but I said that the port must be 27024. The command rcon_port is ignored, but there is no failure message that the command is not found. Oo
rcon_port goes in server.cfg.
[Image: userbar_wow.jpg]
starting 9/24/2006 if your problem has been solved please edit your first post and add [solved] to the begining of the title. Thanks.
cryotek Wrote:rcon_port goes in server.cfg.

I put it so in the server.cfg:

rcon_port 666

This message appears:

Unknown command "rcon_port"

I really need a solution to this. Ive tried steam support, but they only gave me an answer that they dont give support(?!?) for srcds.

I run 2 srcds css servers on the same machine, both works fine, except for RCON that will only work on the server i start first.

The rcon_port cmd gives me "unknown command". And i really dont feel like buying a extra NIC just for this.

try using +10 ports at least for every server

so if the first one's 27015, run the second one at 27025 etc etc
I had a 7!!! server machine on a 1800man LAN party and it worked perfect for 11 days.
Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)
I still cannot connect to rcon even using port 27015 and 27025, though everything else works.

Forum Jump:

Users browsing this thread: 1 Guest(s)