SRCDS Steam group


[solved] IPtables wont recognise SRCDS?
#1
Question 
Hi all! Big Grin

Just wondering if any of you guys could possibly help me, I'm using Fedora 4 on a dedicated server. I've set up a seperate useraccount to access my CSS server and also input all the rules and ports into iptables.

Yet when I fire up the server iptables dosn't seem to recognise it as it dosn't show a reference to it, after starting the server I ctrl a+d out and go back double check with "service iptables status" and I get:

Code:
Chain counterstrike (0 references)
target     prot opt source               destination
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           tcp dpt:27015
ACCEPT     udp  --  0.0.0.0/0            0.0.0.0/0           udp dpt:27020
ACCEPT     udp  --  0.0.0.0/0            0.0.0.0/0           udp dpt:27015

As far as I know it should show 1 reference to the SRCDS no?... so what the heck have I done wrong ? I've tried turning off iptables and the server shows up no problems in HLSW etc, but I'm at a loss as to why, something to do with user persmissions or something??

if anyone has any ideas, or point me in the right direction they would be much appreciated, Smile I've spent about 8 hours trying to sus this problem out and it's totally demoralising me :/ ....aaiieee!!!


Cheers!


edit: followed my own advice in this thread: http://forums.srcds.com/viewtopic/1054

but I forgot to use "create a rule at position 1 in the default INPUT chain: iptables -I INPUT -j counterstrike"

- deleted chains and started again (this time paying more attention) seemed to fix it. Damn my failing memory...
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)