SRCDS Steam group

[SOLVED] Pls help! Trying to sort out my new server!
Hi all!

Great forum and really appreciate the info provided here, it's been helping me to get this far! Big Grin

Problem: I can set up and run my CS:S dedicated server on my linux box, I type status and everything appears normal, so far so good.

Only problem is, I can't connect to it. Nor will any game browsers detect it :/ Using (default?) port 27015. I've added the server IP to the command line when starting the server.

[./srcds_run -console -game cstrike -port 27015 +ip +map de_dust +maxplayers 18]

gcc (GCC) 3.3.3 20040412 (Red Hat Linux 3.3.3-7)
ldd (GNU libc) 2.3.3
Linux localhost.localdomain 2.6.10-1.14_FC2 #1 Thu Feb 10 17:13:14 EST 2005 i686 i686 i386 GNU/Linux

[admin@localhost srcds_1]$ ./srcds_run -console -game cstrike -port 27015 +ip +map de_dust +maxplayers 18
Auto detecting CPU
Using SSE2 Optimised binary.
Auto-restarting the server on crash

Console initialized.
Attempted to create unknown entity type event_queue_saveload_proxy!
Game .dll loaded for "Counter-Strike: Source"
maxplayers set to 32
maxplayers set to 18
Network: IP, mode MP, dedicated Yes, ports 27015 SV / 27005 CL
Executing dedicated server config file
Unknown command "sv_aim"
couldn't exec banned_ip.cfg
couldn't exec banned_user.cfg
couldn't exec mani_server.cfg
Server logging enabled.
Server logging data to file logs/L0706006.log
L 07/06/2005 - 04:02:26: Log file started (file "logs/L0706006.log") (game "/home/admin/games/srcds_1/cstrike") (version "2391")
Unknown command "log_level"
couldn't exec de_dust.cfg
L 07/06/2005 - 04:02:29: World triggered "Round_Start"
Adding master server
Adding master server
Connection to Steam servers successful.
hostname:  Test Server
build   :  2391
udp/ip  :
map     :  de_dust at: 0 x, 0 y, 0 z
players :  0 (18 max)

# userid name uniqueid connected ping loss state adr

I can see it's missing some files on booting up but shouldn't be anything serious, as I plan to install mani and tidy up the server.cfg to sort these minor niggles out.

Only thing I can think of is maybe the ports are blocked. Sorry for my ignorance, but if it is the ports as i suspect how do you go about unblocking these ports? Although I don't think the server should be able to connect to the master server list if this was the case, no?

I dunno it's got me beat...

Any help would be gratfully received.

well, ports would have nothign to do with an internal connection, you need ports opened for people outside to connect. try not adding your ip?are you adding your WAN (assigned by your ISP) or your LAN(assigned by your router, looks like
[Image: userbar_wow.jpg]
starting 9/24/2006 if your problem has been solved please edit your first post and add [solved] to the begining of the title. Thanks.
Thanks for replying Cryotek,

If I don't add the IP then the server gets assigned to the IP

When I got the server I was automatically assigned two IP addresses. I've tried using both these with the same results as mentioned in my first post.

Quote:are you adding your WAN (assigned by your ISP) or your LAN(assigned by your router, looks like

Not really sure what you mean here. I don't have a router, and no IP's of that discription 192.168.etc.

Damn this is frustrating!

Anymore ideas? I'm rapidly running out of them, except maybe jump out the window of my 10 storey apt... :/

Thanks in advance!
Oh, ok so this is a dedicated server at a datacenter, correct?

I would check with the host of the server about firewall ports. thats the only thing i can see being the problem.
[Image: userbar_wow.jpg]
starting 9/24/2006 if your problem has been solved please edit your first post and add [solved] to the begining of the title. Thanks.
Yes Cryo it's a dedicated server hosted at a datacenter.

I've already tried contacting the hosts this was the response:

"You may need to configure Iptables (which is the default Firewall) to allow traffic on the ports your Source server is running on. By default the Srcds runs on port 27015 so you will need to ensure this is open (however as it is such a high port number it may be already).

A good Linux Source dedicated server guide can be found here:

I would also advise you to check the Steam FAQ's.


As you may have already guessed im pretty new to Linux, any ideas how i can unblock the required ports?

I use Fedora Core 3, and am also a beginner, but I did manage to open the ports. Try going to Applications (if you have Vino access) > System Settings > Security Level > Enter ROOT Password > There you see in the bottom window in the firewall options tab, "Other ports". Type "27015:tcp, 27015:udp" to open ports on iptables for srcds. Click Ok.
Now, just to be sure, open the console, log in as root, and type service iptables status. That shows the status of iptables. If you see the right ports there, then try starting the server.
Thanks Rusty, I just had to learn to change IPtables manually, thankfully through the power of google and a good friend who helped me set it up.

Just incase anyone else is interested the way it was done was something like this:

create a new chain: iptables -N counterstrike
create a rule at position 1 in the default INPUT chain: iptables -I INPUT -j counterstrike
The -I (that's a capital i) means insert and puts the rule at position 1 by default, or you can specifiy a position if you need to)
The -j tells it to "jump" to the counterstrike chain to look for a match.

You then need to set up your specific rules for the CS server and put them in the counterstrike chain.
For each port you need to set up: iptables -A counterstrike -p tcp --dport PORTNUMBERHERE -j ACCEPT

The -A appends the rules to the end of the chain.
swap "tcp" for "udp" as needed and put the destination port number in the obvious place
The -j this time tells it to accept the packet and your server should then deal with it.

If it all goes wrong:

Delete all rules from a chain (careful, don't mess with the default INPUT, FORWARD & OUTPUT chains: iptables -F counterstrike
Delete the chain once it's empty: iptables -X counterstrike
Delete a specific rule (like the one we put in the INPUT chain): iptables -D INPUT 1 (where INPUT is the name of the chain, and 1 is the rule number you want to delete)

I now have my CS:S server! Smile

Thanks to all for your help!


Forum Jump:

Users browsing this thread: 1 Guest(s)