SRCDS Steam group

Steam master listing obscure port
There is something weird going on with the dedicated servers I put up behind my FreeBSD router (m0n0wall). I'm using inbound NAT port forwarding. When I put up a CS Source server running on port 27015, the server comes up in the steam master listing as running on port 9895. Here is my command line:
Quote:srcds.exe -console -game cstrike -port 27015 +sv_lan 0 +map de_dust +maxplayers 16
If I increment the local port by 1 to 27016, the master lists an incremented port also at 9896. I found out this info by querying the master server with QStat ( - looks to be down now though) using the following command from linux on another network:
Quote:qstat -stma2s,game=cstrike,region=0,status=dedicated |grep
Quote:A2S no response
In the query above, is my WAN IP and you see the server in the result being listed with the weird 9895 port.
When I forward port 27015 in my router, clients can connect by going directly to But if I want clients to connect from the server browser list, my server shows up as so I have to forward WAN port 9895 to the LAN port 27015 to let them in.

This issue happens with both Goldsrc and Source dedicated servers. My server's OS is Win2k3, and no software firewalls are installed. All of my other port forwards are working properly - SSH, HTTP, FTP, etc. I think this issue is specific to hlds/srcds when they are ran behind a restrictive firewall.

Here are the ports I've forwarded for hlds/srcds... with a little bit extra added for the multiple servers I run.

TCP 27015-27020 (RCON)
TCP 27030-27039
TCP/UDP 26900-26905 (VAC auth)
UDP 1200-1205
UDP 27000-27020

What is causing the master server to list me at this obscure port? Any help you guys have to offer will be much appreciated.
[FORD] CS:S GunGame - -
Asero Gaming Community -
I think it means the ports are not forwarded totally correct
Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)

In m0n0wall I had to enable advanced outbound NAT. Add a new outbound mapping: Interface - WAN, Source -, Destination - any, Target - blank, Portmap - check Disable port mapping.
[FORD] CS:S GunGame - -
Asero Gaming Community -

Forum Jump:

Users browsing this thread: 1 Guest(s)