SRCDS Steam group

CPU Usage
I have one CS:S Server, 100 tick, 20 users, P4 2.66 GHz 1 GB ram, Now, currently there are 10/20 users, and the cpu usage is at 50%, any ideas how to get it at a lower usage?
run lower tick
Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)
I have a similar problem. But the only thing is, it's not using more then 50%CPU. And as an effect, the server FPS drop to 10 - Incredible laggy.
But my server is a GarrysMod server.
Ok, I'll try running at 66
aVoN are you using pingbooster? if not, you should
Also, did you recompile your kernel? This will boost your FPS big time
Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)
Drocona Wrote:aVoN are you using pingbooster? if not, you should
Also, did you recompile your kernel? This will boost your FPS big time

I never tried to recompile the kernl. I don't wanna damage my server (I'm not a Linux geek Wink)
The only problem is, my FPS drop, because the servercpu doesn't go above the 50% border. When it's below 50 (47% or so), it's constantly at 333 fps (or around). But when it hits 50%, it wents down.

So, anyway, to change this behaviour? ulimit showed me, that i have an unlimited useraccount concerning the CPU time. So, why does SRCDS not does over 50% cpu?
If you want avon, i can login with a user account that has access to sudo/su and recompile the kernel so you don't have to give out your root password. to do this, my username would need to be in /etc/sudoers where a password is not needed, and my user needs to be in the group wheel
[Image: userbar_wow.jpg]
starting 9/24/2006 if your problem has been solved please edit your first post and add [solved] to the begining of the title. Thanks.
can you just post what needs to be done to recompile the kernel?
sure for centos you do this, other distros would be similar but not exactly the same:

cd /usr/src/
tar -zxf linux-
cd linux-

cp /boot/config-2.6.9-22.0.2.EL .config
make clean (only necessary if you compile more than once)
make oldconfig

keep hitting enter and take the defaults until you get to the CPU type. Select your CPU. After selecting your CPU, the kernel timer will come up, select 1000hz instead of the default 250hz. Also in the SMP section select SMP if you have multiple CPUs. Oh, and select "(No Forced Preemption (server))" under that section. Everything else, just hit enter to take the defaults.

(this is the "quick and dirty" method. You can also run "make menuconfig" instead, go to the bottom of the menu, load your old config file, and then select everything in a menu individually if you wish. For most systems, the "make oldconfig" method works fine.)

Then to compile and install:

make bzImage
make modules
make modules_install
make install

Then to configure your boot loader in case of disaster:

nano /boot/grub/grub.conf
title CentOS (
    root (hd0,0)
    kernel /vmlinuz- ro root=/dev/VolGroup00/LogVol00
    initrd /initrd-
title CentOS (2.6.9-22.0.2.EL)
    root (hd0,0)
    kernel /vmlinuz-2.6.9-22.0.2.EL ro root=/dev/VolGroup00/LogVol00
    initrd /initrd-2.6.9-22.0.2.EL.img
title CentOS_ServerCD (2.6.9-22.EL)
    root (hd0,0)
    kernel /vmlinuz-2.6.9-22.EL ro root=/dev/VolGroup00/LogVol00
    initrd /initrd-2.6.9-22.EL.img
..make sure it looks something like this with default=1 and the new kernel ( on top. (Grub starts at 0, so "default=1" is still your old kernel. You change this later if it works out ok)

..then configure grub to boot to the new kernel one time. This way if it panicks or you can't get to the machine because the network service blows up, you can have the data center do a reboot and it will default back to the last kernel. If it does boot ok and everything looks good, edit grub.conf again and change it to "default=0" and it will boot the new kernel by default after that.

savedefault --default=0 --once

just update the wget command with the latest kernel and you're set. oh if you jack up your machine don't blame me. Big Grin i've done it this way to many machines without issues.
is there a "quick and clean" way or would that be the 'make menuconfig'

and is there anything else i need to do for multiple cpus beside select it?
if you do make menuconfig, it will come up as a text menu but you have to dig through to select stuff, it's just easier to to make oldconfig, read the each option semi-carefully and change the ones you have to change ie the quick and dirty way. after you do the 3 you need to check for sure, you don't really have to look any more, just keep pounding "return" until it's done.

i believe there's one option for hyperthreading and another for actual separate cores or cpus, you'll see when you get to it.
sorry one more question do i have to upgrade my kernel, or can i just stay with the one i have
( something like that) thanks for answering my prolly stupid and easy questions.
that's up to you, go to and see what fixes they have for each one.
If CPU load never comes over 50% you probably have HT, disabled Hyper Trading in the bios.
[Image: banner.gif]

Well i suck at everything i cant seem to get this to work. I installed the kernel source for my kernel and that went good (suprise suprise) but then i when i do the cp /boot/kernel-blah.blah.blah .config that works but when i do 'make oldconfig' it just runs through everything without leting me choose the options, and when i do a make menuconfig i cant find the options such as the kernel timer and the preemptive whatever.

i am willing to give who ever wants to do this access to my server just pm me and ill give it to you.


Forum Jump:

Users browsing this thread: 1 Guest(s)