SRCDS Steam group

CS:S Update Issue: "Compression Failure"
Problem solved... if anyone else has the compression error problem, remove the files listed above (ClientRegistry.blob and InstallRecord.blob) and then ALSO delete the file listed just before the compression error.
theansaname Wrote:I get error here

Verifying: .hl2modelsprops_combinecombinetower001.vvd
Downloading: .hl2modelsprops_combinecombinetower001.vvd
Compression Failure

cd ~/.steam
rm ClientRegistry.blob
cd ~/srcds_l
rm InstallRecord.blob

mv /usr/bin/uncompress /usr/bin/uncompress_
ln -s /usr/bin/gzip /usr/bin/uncompress

both do not work
I've got the exact same error. I'm on try #4 and it still won't verify it!

I've done both solutions. Help? Sad
I've tried everything in this thread so far. No luck.

Still fails at office

[root@serv srcds_l]# gzip -help
gzip 1.3.3

what version of gzip do you guys have?

Try downloading office from a cs maps site. if that don't work, instead of linking, try installing ncompress
[Image: userbar_wow.jpg]
starting 9/24/2006 if your problem has been solved please edit your first post and add [solved] to the begining of the title. Thanks.
Make sure you delete the last file the error occurred on. I got mine to work when i deleted the file combine tower.

Well I have the same error (Compression Failure) with the file Generic64b.vmt which is placed in cstrike/material/de_aztec.

I have tried to delete both installrecord.blob and the Generic64b.vmt file but it stops there every time ...

So now what??
cd ~/.steam
rm ClientRegistry.blob
cd ~/srcds_l
rm InstallRecord.blob

AND Generic64b.vmt
I also had this compression problem earlier (with cs_office.bsp).. and the only way I got it to work was to create a new steam account.
I'm having the problem (crow.wav is where mine breaks.)

I tried all the ideas above, still no love.

Before I try to install ncompress, I'd like to ask if this will be ok on a FreeBSD 4.11 system?

...and if so, where's the official, or best place to find ncompress?

I assume that if I were to install ncompress, I'd have to redo the link to point uncompress to ncompress?



PS My gzip version is gzip 1.2.4 (18 Aug 93)
My uncompress is uncompress 1.2.4 (18 Aug 93)


I didn't have to install ncompress.
A thread on another forum said to link to gunzip, not gzip.
Doing this made the install work for me!
Victory is mine!

Here is a recap of how I got around the 'compression failure' on my system:

rm ~/.steam/ClientRegistry.blob

rm ~/srcds_l/InstallRecord.blob

rm <file that compression failed on for you>

mv /usr/bin/uncompress /usr/bin/uncompress_

ln -s /usr/bin/gunzip /usr/bin/uncompress

../steam -command update "Counter-Strike Source" -dir . -verify_all

NOTE I didnt have to use any -login -question arguments. Never did for this entire install attempt. Maybe Valve changed that login requirement?
ahhhhh compression failure. i tried everything in the thread to fix it and non of them have worked. except i could not find the client registery.blob. it downloaded fine when i was on the root acc just when im on my plain one it just get to the .\cstrike\models\humans\male_shared.ani
and stops.

anyhelp is appreciated

I'd say start over, but find that blob and rm it, might as well try what worked for other folks.
theres 3 files and its not one of iono ill just try to run it off the root acc
im having same problem here but with shell_556.vtf maybe this is something steam needs to work on? seems like alot of problems for it to become a sticky. Ive tried new accounts removing everything and starting over with the tutorial on this site and same thing. ive done the uncompress to gzip thing still no go. can anyone just send me the file :-)

here is my server info:

gzip 1.2.4 (18 Aug 93)

gcc (GCC) 3.4.2 [FreeBSD] 20040728

FreeBSD 5.3-RELEASE #0: Fri Nov 5 04:19:18 UTC 2004

that ldd command gives me errors:
Quote:bash-2.05b# ldd --version
ldd: illegal option -- -
usage: ldd [-a] [-v] [-f format] program ...
You'll need to link to gunzip NOT gzip.

I'm sending your a private message with some steps that got mine working. (or read my post a few before yours)
I have about the same system setup as you.
If i was to host my completed install on the net for ppl to download files that they had "compression failure" on, would there be any issues with this?

oh & btw, me & 2 other mates have had this issue so do this:

remove the Install.blob file
remove the ClientInstall.blob file
remove the file that was causing the issue along with any other file that has the same name but different extension.

has worked 3 times for me now.

Forum Jump:

Users browsing this thread: 1 Guest(s)