SRCDS Steam group

CS:S Update Issue: "Compression Failure"
The best fix I found (and I tried ALL OF THEM) is to use gcf-scape ( to extract the files the installer chokes on from a windows install then manually rename(if necessary) and move them into place & set perms. I didnt have to delete any .blob files or use any secondary logins using this method. It seems to be a problem with steam-*ux and should be addressed!
Mine choked on these files in this order):
Prior to 4/6/05 update
after 4/6/05 update
woodframe_courtyard_n.vvd <-(needed to rename windows file woodframe_courtyard_N.vvd to woodframe_courtyard_n.vvd)
ncompress is required to run the hldsupdatetool.bin. From that you get the steam executable. Most linux systems have ncompress installed already, but some don't. This has nothing to do with this error however.

The problem is the content server is corrupt in some way. Either in the data is has, or in the process files are handed out. The reason deleting the blob files *sometimes* works is the content server the steam binary chose to use on first run is stored in there. When the ClientRegistry.blob file is removed the steam binary starts all over and chooses whatever content server it thinks best suites you, which may be different than the one giving you these bad files.

-verify_all will not work because the issue is with the content server.

ripping the files with gfscape or getting them from another server already updated would temporarily solve the problem too.

Now here's what you want to do. . . .
Run this:
./steam -command ticketexplorer
This will output a page and a half of info. Copy that info along with the line showing what file the compression failure occured on and email directly with this info.

Note: Alfreds email is publicly available, but don't be silly and just start sending him questions. This information however I know he will want to see. I had the same problem and he pulled the offending content server offline.
hi there

my solution was:

rm InstallRecord.blob
./steam -command update -game "hl2mp" -dir . -verify

i tried it a couple of times and finnaly somehow it worked.

this error made me already nuts befor i found this forum Big Grin

update: WTF? stopped the install over night and now it cant go on or even start a new one, this is so frustratingSad
Downloading: /home/reveal/hlds_l/\cstrike\maps\de_piranesi.bsp
Compression Failure

I've tried all the replies of how to fix it.

I run gentoo kernel 2.6-14

I run the following that produces that error

./steam -command update -game "Counter-Strike Source" -dir /home/reveal/hlds_l/ -verify -retry
my problem this time is about -autoupate command
i use it on and if i trying to run sh file the physical server stop working, even sourcebans on same box doesn't open
i can't long in anymore to box , no access "putty + FTP"
i have to restart Box and remove -autoupdate command from then css servers works fine and box

Forum Jump:

Users browsing this thread: 1 Guest(s)