SRCDS Steam group

CS:S LAN Server queries Auth-Server
Hi Forum,

I've set up my LAN Server following the tutorial.
I start my Server with the offline parameters (-insecure -nomaster +sv_lan 1 +ip and it starts just fine on the console.
But the Server is not accessible. Viewing it with HLSW shows a timeout 95% of the time and 5% of the time the ping is around 200.
If the server still has connection to the INet via router it's all right - no high ping, everything fine.
But in Pure offline-mode it won't.
I've used Ethereal to monitor the connection and I found out that my LAN Server tries to connect to the authentication server: - which is
What is the problem here? I can't understand why this damn thing still tries to authenticate
Is the order in which the parameters are given important?
Iv'e tried a fresh installation and a copy of a server running dedicated on the INet, both show the same symptoms.
So it's not the plugins or setting.

Totally confused - Pollux
I've made some progress...
The client got his IP by DHCP.
I just set the IP manually and set no gateway or nameserver - now the CS:S LAN-Server is running without lags or timeouts - but it's not shown in the source-client serverlist.
In HLSW it is only listed after manually adding the IP.
What's my problem now please?

I dont know alot about linux but maybe you could try to add hostport to the command line and put sv_lan in your cfg instead of cmd line
Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)
Nah, that didn't do the trick Sad
I'm really wondering what I'm doing wrong here, there are no obvious errors left or I can't see them.

The Logs stay empty and the console looks like this:

Quote:Auto detecting CPU
Using AMD Optimised binary.
Auto-restarting the server on crash

Console initialized.
Attempted to create unknown entity type event_queue_saveload_proxy!
Game.dll loaded for "Counter-Strike: Source"
maxplayers set to 12
Network: IP, mode MP, dedicated Yes, ports 27016 SV / 27005 CL
Executing dedicated server config file
Summary: 343 resources total 14.96 Mb, 22.29 % of capacity
Server logging enabled.
Server logging data to file logs/L0404007.log
L 04/04/2006 - 17:32:00: Log file started (file "logs/L0404007.log") (game "/home/hades/source/cstrike") (version "2677")
couldn't exec banned_user.cfg
couldn't exec banned_ip.cfg
Master server communication disabled.
L 04/04/2006 - 17:32:06: World triggered "Round_Start"

I'm having a LAN on Friday through Sunday with 5 Servers and I really need this thing up and running - this makes me wanna cry out loud!!!
Well i have no idea what to do... Never had problems like these.

As I said i dont know how linux works exactly but if you really can't get it to work set up a domain name on your network for your pc.
It should be really easy to do, just set the domain name to go to your LAN ip adress. for example you could make server1.lan server2.lan server3.lan etc

then your lan party friends would only have to enter that LAN domain for the server and they will connect.
Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)
I must admit I was wrong assuming I figured out the Timeout-Problem Sad
I only set IP and Nameserver manually and forgot about the gateway which was still set so it still authenticated in the INet. As soon as I pull the plug to the router the server throws out a whole lot of ARP-packets and has 90% timeout.
I CAN connect to the server but it takes about 5 minutes connect and always shows "connection problem" in the top right corner- it's just not usable.
When omitting the +ip it does show up in the HLSW (and if it didn't have a timeout it would also show in the Source-Serverlist) but I just dont't get the grip on the timeout!!!

Here are my results:

I noticed that on my server there is running samba by default.
/etc/init.d/smb stop
did the job. Now the server is running fine - no problems anymore.

Thank you Drocona for involving,

no problem, good to see you solved it Smile
Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)
I've got the same problem on a Suse 10.0 System but there is no smb running. Has anybody made progress with this problem?

Forum Jump:

Users browsing this thread: 1 Guest(s)