SRCDS Steam group

Suddenly Lost RCON?
all of the sudden my server has lost RCON, whenever myself or one of my other admins tries to run an rcon command it says:

RCON connection failed <WSAEAFNOSUPPORT>
Unable to connect to remote server <unknown>
Lost Rcon connection, please retry command <unknown error>

i have the server ip set in the server.cfg

it used to work fine, and i didnt change any just "poof" stopped working..

any help would be greatly appreciated..
hmm.. did windows update? lol. cuz i know awhile ago windows updated the firewall and now you have to manually open the port to allow rcon through it. (thats server side btw)
i have the port forwarded, both on the server side comp, and on the router...
tcp as well as udp?
Have you checked to make sure your server is at the latest version?

Have you tried a program like HLSW?

Have you made sure that the rcon cvars were not removed or changed?

Answering those can allow skeletor and I to help you more
Have you checked to make sure your server is at the latest version?

yes i have, i ran the hldsupdatetool shortly after the latest css update.

Have you tried a program like HLSW?

yup have that installed as well, whenever i try and use the rcon commands it gives me an error and says "disconnecting"

Have you made sure that the rcon cvars were not removed or changed?

not exactly sure what you mean here...i checked my server.cfg and everything seemed in order, i have my rcon_password **** and ip set in there.

thanks for your replies...hopefully we can figure this out soon
For sure not opened 1 or more ports, forward them and open them in you firewall.
yea this is the main thing i can think of.. is somewhere a port isn't opened right.
i checked all the ports and all the correct ones seem to be open.

when i type rcon into the console, i get:
cannot connect to remote server <>

i even tried putting the router in DMZ but still no rcon
even on the firewall of the computer hosting the server..
yes i have
well then i thnk im officially out of ideas.. lol. cuz if all the ports are open in the router and firewall, and the rcon password is assigned right in the server.cfg file, then it should work. unless theres something im overlooking..

sorry im not much help on this Sad
i will double check the ports on the server computer, but im pretty sure i opened all the correct ones..

i tried re-making a server.cfg but that didnt seem to work, i have:

rcon_password "*****"

included in the .cfg

the only other thing i can think of is maybe uninstalling srcds, then reinstalling and starting over from scratch?
also...(sorry for double post)

i use serverchecker v 3.1, and whenever i try putting +ip -port 27015 into the command line, it gives me "error allocating dedicated port" or something like that

this whole thing is probably just a stupid mistake that im overlooking...thanks for all your help though

Forum Jump:

Users browsing this thread: 1 Guest(s)