SRCDS Steam group

Server resets after playing for a few seconds
So I built myself a 2nd computer to use as a server for Gmod and TF2, but it keeps crashing after a few seconds of me joining.

OS: Ubuntu 11.04 (natty) 32bit
CPU: AMD Athlon 64 x2 5200+
RAM: 2gb
Game: Gmod (haven't tried TF2 yet)
Startup Command: orangebox/srcds_run -console -game garrysmod +maxplayers 8 +map gm_construct -autoupdate -debug
Mods: n/a

Not too long after I join, I get this message:

Quote:PreMinidumpCallback: updating dump comment
Uploading dump (in-process) [proxy '']
success = yes
response: CrashID=bp-211793db-1090-4417-b206-d73a62110702

BFD: Warning: /home/zeserver/srcds/orangebox/core is truncated: expected core file size >= 154615808, found: 2088960.
Failed to read a valid object file image from memory.
debug.cmds:5: Error in sourced command file:
No function contains program counter for selected frame.
email debug.log to
Sat Jul 2 16:16:57 EDT 2011: Server restart in 10 seconds

And if anyone can make heads-or-tails of this, here's the log for that session:
CRASH: Sat Jul 2 16:16:57 EDT 2011
Start Line: ./srcds_linux -console -game garrysmod +maxplayers 8 +map gm_construct -autoupdate -debug
[New Thread 5762]
[New Thread 5770]
[New Thread 5766]
[New Thread 5768]
[New Thread 5763]
[New Thread 5764]
Core was generated by `./srcds_linux -console -game garrysmod +maxplayers 8 +map gm_construct -autoupd'.
Program terminated with signal 11, Segmentation fault.
#0 0x00a540ae in ?? ()
#0 0x00a540ae in ?? ()
#1 0x00000000 in ?? ()
No symbol table info available.
eax 0xb6f580 11990400
ecx 0x196668 1664616
edx 0x7d649cc 131484108
ebx 0xb6eff4 11988980
esp 0x193fc4 0x193fc4
ebp 0x1960a4 0x1960a4
esi 0xb6f580 11990400
edi 0xd01ff0 13639664
eip 0xa540ae 0xa540ae
eflags 0x10202 [ IF RF ]
cs 0x73 115
ss 0x7b 123
ds 0x7b 123
es 0x7b 123
fs 0x0 0
gs 0x33 51
From To Syms Read Shared Object Library
0x005d8830 0x005ef4af Yes (*) /lib/
(*): Shared library is missing debugging information.
End of Source crash report

I'm in no way a newb when it comes to computers or linux, but this server thing has me stumped. I appreciate any help anyone can give.
I've been running my TF2 server for well over a year with little to no problems. And this morning I noticed I am have the EXACT same problems as you. So you are not alone. I just wish I knew what the solution was.

Found the answer to our problem in this thread I tried it and now my server is running again with no problems.

Forum Jump:

Users browsing this thread: 1 Guest(s)