SRCDS Steam group

100% cpu usage with 1 10man?
alright so my server is a 2.4ghz celeron, and I hit 100% cpu usage with one 10man server, does this sound right at all?

its fedora 4 running 2.6.11 kernel.. I was thinking selinux might be the problem

if any mods wanted to disable that for me if it was the problem, i'd be much greatful Big Grin
any comments at all?
any comments at all?
is this common/uncommon? i know celeron's arn't the greatest processors but 1 10 man server..
Are you running anything like X11? yanno, X-windows, with gnome or KDE?
[Image: userbar_wow.jpg]
starting 9/24/2006 if your problem has been solved please edit your first post and add [solved] to the begining of the title. Thanks.
nope, top says the only thing taking any cpu is srcds
its rented from a company with space in Equinix in chicago
Dosen't sound right at all. I've ran 20 person public servers on 2.0 GHZ celerons w/66 tickrate.
Game Server Administration Services
Linux & Windows performance specialist.
thats what I thought.. I mean it is 100 tick but still, i can run a 10 man 100tick on the 1.8ghz celeron i have beside me, though it is celeron

edit: is there a command to check your cpu frequency? seeing as I 've never physically seen the computer there's no way I don't know they didn't screw me
to see cpu info run.

cat /proc/cpuinfo
or maybe its
cat /proc/cpu
Game Server Administration Services
Linux & Windows performance specialist.
processor : 0
vendor_id : GenuineIntel
cpu family : 15
model : 2
model name : Intel® Celeron® CPU 2.40GHz
stepping : 9
cpu MHz : 2424.190
cache size : 128 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe cid xtpr
bogomips : 4800.51

and uname is...

Linux 2.6.11-1.1369_FC4 #1 Thu Jun 2 22:55:56 EDT 2005 i686 i686 i386 GNU/Linux

Anything wrong yet?
I see that your box is hosted with SteadfastNetworks, good choice. Talk with Karl(owner) over there, he knows his stuff. I would try to update your kernel.

Are you running the server in a screen?
Game Server Administration Services
Linux & Windows performance specialist.
Yep its in a screen, and yeah Karl has been awesome so far working with me. I was about to do just that, maybe with a vinilla kernel or something but I keep hitting so many issues. Right now when I try to rpmbuild it stops halfway through ><

[root@ds00827 ~]# rpmbuild -bp --target=noarch /usr/src/redhat/SPECS/kernel-2.6.spec
Building target platforms: noarch
Building for target noarch
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.58941
+ umask 022
+ cd /usr/src/redhat/BUILD
+ export LANG
+ unset DISPLAY
+ cd /usr/src/redhat/BUILD
+ rm -rf kernel-2.6.11
+ /bin/mkdir -p kernel-2.6.11
+ cd kernel-2.6.11
+ /usr/bin/bzip2 -dc /usr/src/redhat/SOURCES/linux-2.6.11.tar.bz2
+ tar -xf -

and it sits there...

edit: lol nm seems I'm just not pacient enough
well i customized the kernel a bit, changed a few things that i'm pretty sure are arbitrary anyways but just to see if it helped (the processor type to pentium-4 based celeron ect) and still having the same problems.... 10-15% cpu per player

Forum Jump:

Users browsing this thread: 1 Guest(s)