SRCDS Steam group

How do you create Left 4 Dead 2 Turbo Server?
I apolgize if I post this in the wrong thread but I don't where to post this and I apolgize for being a total new person on touching this matter.

I played in a server on l4d2 called ruxpin, there a turbo server with unlimited ammo, gravity jump high, health (starts at +888), spawn objects through console using props_dynamic_create /props....., etc. I wonder how can I get this in my dedicated server (I downloaded by doing the hldsupdatetool, and everything), i think its the plugins or something in the addons but I don't know that much about this matter, again I am a total newbie on this subject, please I ask for assistance

Thank you
I think they used this sourcemod plugin.
You need to install metamod source and sourcemod.
Here are some documentation on installing metamod source and sourcemod.
You can use these l4d server setup guides for help. Similar to l4d2 server setup.
As for the other server side plugins or mods, they could have possibly used more sourcemod plugins or Mattie's Eventscripts.
Earn Points, get Free Rewards with your Amazon Points!

thanks for this info, but when I installed metamod and source in the addons (meaning got the two .zip and dragged it to the addons folder) so I have metamod (version 1.7.1) and sourcemod (version 1.2.4) folder with sourcemod.vdf in metamod (it was with the sourcemod 1.2.4 zip file), then I generated the metamod.vdf (just selected windows and left 4 dead 2) and placed in the addons folder (no sub directories), then I ran the srcd.exe (without the target line ex. -console ......) then when I start it, a error message comes up: "srcds.exe is not responding" and then I ran srcds.exe (this time with the target line, all correct), it gave me a command prompt then it said: "srcds.exe is not responding"

I did every step right, I even reinstalled metamod and sourcemod and still it gave me the same I have to configure metamods and sourcemod and the addons I would put in the server.cfg? idk why I'm getting this error, but when I clear everything in the addons folder and the sourcemod folder in the cfg (this too came with sourcemod 1.2.4), it worked (clicking on the srcds.exe without the target perimeter) and started the server it ran fine but its when I add the metamod and sourcemod...any solution?

UPDATED: I am trying to use the other Metamod Source download (file name: mmsource-1.7.1.tar, the .gz), I deleted the mmsource from .rar and add this file, I ran the server (without the target line) it worked, but now when I type "meta list" it said "unknown meta" ??, btw I did this on the SERVER CONSOLE not in the left 4 dead 2 game console
Are you sure you're installing it correctly? Read up on the metamod documentation, they have pretty good how to's.
Looking for a game server? Visit and pick one up as low as $2.50 / mo!
Please do NOT do any steps at the same time.

First, install server => try if it works.
Second, install metamod => start server see if metamod is running (plugin_print, meta version)
Third, install sourcemod => start server see if sourcemod is running
Fourth, install extra sourcemod plugin => again start and see if it works
Fifth, start editing the configuration.
Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)
Disregard the plugin I suggested. It's for tf2. Let me see if I can find what your saying.

Here's a list of l4d sourcemod plugins from searching through their site, but there might be more than that amount. You should register on that site and look around their forums.

Or they could have used Mattie's Eventscripts to customize their server to do those various settings you mention.
Earn Points, get Free Rewards with your Amazon Points!

ya the second part where I install the metamod, the scrds crashes when ever I put the generated metamod.vdf file in the addons or I try adding the line in gameinfo.txt, it crashes but without the .vdf and without adding the lines in .txt it works (typing meta version) but it keep saying: unknown command "meta"

I think im getting a headache from this, I don't know what the problem is, either delete the whole srcds folder and redownload the game I want to host and try that but to me I don't think it would work, same result but idk, i did the steps you told me one by one, it works with just the server, then I just add metamod folder and started the server it works fine but the unknown command list in console, then I put the .vdf (for the generated one for left 4 dead 2) in the addons and it crashes

I give up Sad
As of right now Sourcemod doesn't support L4D2. They are currently working on a Beta version of Metamod v1.8 that does currently work with L4D2, but again it's beta and may not be stable.

They haven't even touched sourcemod in terms of compatibility for L4D2, so whichever server you played on was either a beta test from the Sourcemod dev team, or they were running Eventscripts or something else on the server.

You can keep up to date with the status on their mainpage -
Mohawk Voice v1.0 now available!
[Image: 331lwzt.jpg]

Forum Jump:

Users browsing this thread: 1 Guest(s)