SRCDS Steam group

Extreme lag on standalone TF2 LAN server
Server OS: Windows XP Professional
Processor: Core 2 Duo 6.67 GHZ
Ram: 2GB
Game(s): Team Fortress 2
Start Up Command: srcds.exe -console -ip -port 27015 -game tf +maxplayers 24 +map ctf_2fort
Admin Mods: None; just trying to get it working to start with

Hi, I am attempting to set up a dedicated server for an upcoming LAN party I will be helping to run. So far, I haven't had much luck. Sad

First off, I would like to state that I am completely new to running a dedicated server. So...forgive me if this is a n00b problem, however I have searched around and have found no such solution so I figured I'd ask.

I have downloaded and installed the HLDS Update Tool. I have set up a TF2 server though that. The server starts up just fine and seems fine from the server side of things. However, the problem is when I try to connect to it from another computer.

First off, the latency is incredibly high for a LAN server I would think (shows between 70 and 100ms in the server browser). It shows as 1ms in game though.

Secondly, probably related, the server is unplayable. Lag is so bad that you can't even switch weapons or start to move without it taking minutes to reflect on the screen.

I know this isn't a client issue because I can play in my own listen server or on the internet just fine.

The CPU usage isn't being maxed out, or even close to it, on the host computer. I've tried playing around with the server rates, but nothing has any affect on the lag.

I'm assuming this is a networking issue of some sort. Firewalls are off on both the host and the client. I've tried forwarding all the ports on my router that TF2 would possibly use (TCP/UDP 27000-27050). Neither had any affect.

Any suggestions?

thanks in advance for any help
Are you running the server off the same computer your playing on?
Ryan White
Owner & CEO
(10-28-2009, 12:23 PM)dualcore1289 Wrote:  Are you running the server off the same computer your playing on?
No, it's on another computer on my home network.
Is there anything else running on the server? Any programs etc.
Try to set the srcds.exe process to high priority in the task manager and se if that helps any.
Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)
That is very strange, massive lag on a dedicated lan server. . . Something is hogging resources. . . CPU, Ram, bw, etc
Ryan White
Owner & CEO
How many people are joining via the LAN? How many via WAN (internet)?
Please post your server.cfg

Can you give us a layout of the network (Where is the modem, router, switches, ect.)? Are clients connecting via wire or wireless?
~ Mooga ...w00t? - on Twitter
[Image: 76561197965445574.png]
Please do not PM me for server related help
fqdn Wrote:if you've seen the any of the matrix movies, a game server is not all that different. it runs a version of the game that handles the entire world for each client connected. that's the 2 sentence explanation.
Is the server on a wireless connection?
Looking for a game server? Visit and pick one up as low as $2.50 / mo!
The lag happens regardless of whether there's people in the server or not. When you join it does the thing like what happens momentarily when you alt-tab back into a full screen game (everything just jutters whenever you attempt to do something). It will take like a minute to start moving and when you switch a weapon out it flips back and forth a bunch of times. It's wierd. Kinda hard to explain without seeing it I guess.

OK...I swapped the client and server and it works fine. I'm running the dedicated server on the computer I was using the client as before, and Vice versa. So, I'm thinking this has something to do with the computer I'm attempting to run it on.

Both computers are plugged into a wired 100Mbps Ethernet connection to the same switch/router
Both have the same amount of memory (2 GB)
Both have a similar processor and chipset (Intel P45, Core 2 Duo 2.67GHz on one and 3.0GHz on the other)
Neither come close to maxing out the CPU or memory when running the dedicated server

The main difference between the two is the graphics processor (does this affect dedicated servers)?
The "good" computer has an nVidia 8800GT
The "bad" computer has integrated intel graphics

Some differences I've noted on the server side:

I've noticed that the FPS shown in the console jumps all over the place on the "bad" computer (going both higher and lower than 256)
It remains at a constant 256 on the "good" computer

The "FPS booster" (running Media Player) has an effect on the good computer (FPS will be below 100 without it)
It has no effect on the bad computer (it runs high either way)

Any suggestions on what to do? Is there some tweak to get the other computer to behave similarly FPS wise, or can the "bad" computer simply not handle running a dedicated server or something?
OK, the lag problem was resolved by running it under Linux (set up to dual-boot) on the machine I want to use as the server. might have been a driver problem with Windows or something, I dunno.

New problem though. I cannot use RCON with this server. Whenever I try to issue a command remotely it says "cannot connect to remote server (". This is the IP address of the server as recognized on the network and by Steam. However, at the server end it is listed as In the "Network Tools" settings under Ubuntu it says

If I set the IP manually to any of these three in the command line when starting the server, it will not show up in the game browser (but will if I let the server set it up automatically). Also typing rcon_address to point to any of these three has no affect on the client end (just says "cannot connect to xxx.x.x.x")

I am running Ubuntu 8.10 64-bit on the host computer

I don't have a huge amount of experience with Linux. I have no clue how I have 3 local IP addresses or how they relate to one another. Any help would be appreciated. I guess I'll copy this new problem to SRCDS: Linux. Big Grin
Or you could have had a virus on the windows system that was eating up your system resources and task manager didn't show it.

Make sure you don't have some sort of firewall running on Linux, I know default installs of linux come with firewalls enabled by default... So double check that any are turned off.
Looking for a game server? Visit and pick one up as low as $2.50 / mo!

Forum Jump:

Users browsing this thread: 1 Guest(s)