SRCDS Steam group

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
High pings
Hi, my CS1.6 warserver is almost finished. It's running a stable 500fps.
But I'm having problems with player pings. I've gotten some complaints about pings and people not wanting to play matches on it. I've also noticed myself that the registry can be pretty bad from time to time.

OS: Debian 5.0
Connection : 30/30mbit

CPU: AMD Athlon™ 64 X2 4450e 2,30GHz.
RAM: 3 072 GB, 800MHz.
HDD: 320GB, 7200 RPM.

HLDS command line:
./hlds_run -game cstrike +ip -port 27015 +map de_nuke +maxplayers 10 +sys_ticrate 566 +fps_max 0 -pingboost 3

mp_autokick 0
mp_autocrosshair 0
mp_autoteambalance 0
mp_buytime .25
mp_consistency 1
mp_c4timer 35
mp_fadetoblack 0
mp_flashlight 1
mp_forcecamera 0
mp_footsteps 1
mp_freezetime 2
mp_friendlyfire 0
mp_hostagepenalty 0
mp_limitteams 6
mp_maxrounds 0
mp_playerid 0
mp_roundtime 1.75
mp_timelimit 999
mp_tkpunish 0
mp_startmoney 16000

sv_maxrate 25000
sv_minrate 0
sv_maxupdaterate 100
sv_minupdaterate 30
sv_unlag 1
sv_maxunlag .5
sv_unlagsamples 1
sv_unlagpush 0
sv_voiceenable 1
sv_aim 0
sv_allowdownload 0
sv_allowupload 0
sv_alltalk 0
sv_proxies 2
sv_cheats 0
sv_clienttrace 1.0
sv_clipmode 0
sv_friction 4
sv_gravity 800
sv_maxspeed 320
sv_airaccelerate 10
sv_airmove 1
sv_send_logos 1
sv_send_resources 1
sv_stepsize 18
sv_stopspeed 75
sv_timeout 65

allow_spectators 0
decalfrequency 60
edgefriction 2
host_framerate 0
pausable 0

Also, can it be because I've only opened the 27015 port? I know there are other ports that should/ are recommended to be forwarded.
Forgot to mention that the machine is behind an Astaro firewall aswell.
I need some help and tips please! Smile

please list your internet speed Http://
[Image: 3386928252.png]
[Image: 455739561.png]

Wow that's weird. The upload speed is supposed to be 30... and the download speed is 38?
Not to mention the ping to the host. It's just nearby. :o
well bandwith doesnt seem to be an issue, did you open ports in your firewall aswell? and you might want to try pf all of the ports. other than that im not sure, your hardware is more than capable of 10 slots so yeah...
[Image: 3386928252.png]
Yeah but as I said, only the 27015 port.
pf sort for port foward Big Grin, like i said try all the ports requried
[Image: 3386928252.png]
Yessir. Toungue
Are you sure that the FPS is stable when the server is full? And have you tried to assign HLDS to 1 core? And do you have a custom kernel? Or just a vanilla?
It's stable with 10 players yes. No I'm not familiar with assigning processes to tasks. I have a RT Patched 1000hz customized kernel.
Im not sure about RT etc for HLDS... I think its better for "source"...
I followed the Linux optimization guide on the fragaholic wiki page. I've also tried a vanilla kernel but it didn't work out as good as with the RT patch etc.
You could try pingboost 2 instead...
I did, no difference.
Do you run "source" and HLDS on the same machine? Thats probably your problem because i think. 1000hz/RT-thing is better for "source"..
Nope. I've tried a vanilla kernel and with default hz etc, it's not better.

Forum Jump:

Users browsing this thread: 1 Guest(s)