SRCDS Steam group

[Resolved] srcds.exe won't open [SOLVED]
I've followed the steps on how to create a counter-strike source server on and i'm on the last step. The last step to start the server via GUI, by double-clicking the srcds.exe executable file. -Nothing happens. Iv'e also followed the tip to make a shortcut to the srcds.exe file and adding this to the target location in the shortcut's properties menu:
-game cstrike
That makes it possible to open the file. So i open it and choose settings for which map it's going to run and so on, and when i click "start", it takess around 10 secs and then it sais (i'm translating from my swedish O.S, windows xp sp3) "The instruction on "0x00df13f7" reffered to the memory on "0x00d1f000". It's not possible to execute this memory action". The following error was returned: The memory could not be "read"."

I've tried starting up my server without the internet enabled, and it works fine, just that i can only play on it as a local server.

I have no idea of how to proceed, because it just refuse to work.
Some people sais that i'm supposed to make a batch file, but it ain't doing the trick either. It's possible that i made a bad batch file though, so if i could get a tip of what to write it would be very helpful.

Soon to be S.E.S clan server
1. Try use this as your shortcut.
-game cstrike -console +map de_dust2

2. Try update your server with verify_all
I tried adding the code, but it didn't work anyway.

I tried updating and it sais up to date.
But if i instead write:

hldsupdatetool -command update -verify_all -game "counter-strike source"

Then it sais that "cannot open blob archive file: CMultiFieldBlob(mem-mapped file): File does not exist and failed to create new file".

Is there a possibility that the error is due to that i have steam and counter-strike installed? If i'm correct, i don't need to have steam and/or counter-strike source installed on the hosting computer.
And is it possible to get another error if i have it installed?

when i wrote:
A list of various things that i could do poped up. among these, it said things about account and password.

Do i have to make an account, or what is it for?

Sorry for beeing a noob at starting up the server.....
hldsupdatetool -command update -game "Counter-Strike Source" -verify_all

Try that.
I tried, and the same message comes up.
Cannot open blob archive file: CMultiFieldBlob(mem-mapped file): File does not exist and failed to create new file.

Since i can start up the server when the internet cable is out, but can't when it's plugged in, doesn't it have something to do with that?
you might want to try to put along with everything else
-dir C:\(location of file)
That didn't work either.

I asked this before but, why can i only start GUI when offline?

If i start GUI when only able to access the local network, i can connect with my laptop, so there's nothing wrong (i presume) with the GUI tool itself, but with my internet settings. Am i correct?

And why do i keep getting the CMultiFieldblob file error?
try this ...

hldsupdatetool -command update -game "counter-strike source" -dir c:\srcds

if that doesnt work run it on another pc and copy the dir ;0)
+ you need to run hldsupdatetool.exe from c:\program files\valve\hlserver

otherwise it wont work at all
I did this and it doesn't work either. Sould my error be to have the server installed in c:\program files\valve\hlserver?
- Am i supposed to have the hldsupdatetool in that directory and install the server in C:\srcds instead?

You can install it anywhere. Is easier to install it into C:/srcds. (More lilely standard).

Also, both HldsUpdateTool.exe and srcds.exe should be in the same directory.
Okay, I've gotten some help from a friend of mine, but the problem hasn't been fully solved --- yet.

I deleted all cfg files except one (valve.rc), and written this when starting the server:
srcds.exe -game cstrike -console
Now the server starts.

- But here's the deal. I type in a command: "changelevel de_dust2".
I get the message: "Can't changelevel, not running server".
- And i can't find the server via steam. I type in the internal ip-address with the port number but cannot connect. (I know that i'm currently running the server on LAN, since i use an internal ip-address. And i've checked that it's possible to connect to the computer(not the srcds server) So the computer is connected to the local network.)

This is what my server command promt looks like:
Start the server with:
srcds.exe -game cstrike -console +map de_dust2

Forum Jump:

Users browsing this thread: 1 Guest(s)