SRCDS Steam group


Gmod servers on non-default ports are not on server list.
#1
BASIC INFO
Server OS: OpenSUSE Leap (latest)
Processor: 2 Xeon 5100 Dual-core 3.0 GHz processors with hyperthreading enabled
Ram: 36 GB
Game: Garry's Mod
Start Up Command: I don't think this applies; this server is in a Docker container.
Admin Mods: ULX/ULib

NETWORK AND BANDWIDTH INFO
Bandwidth: 75? Mbps down/10 Mbps up
Router: Comcrap-supplied Cisco DPC3941T combined modem and router (server on first ethernet port)
Local IP of Server: 10.0.0.28
External IP: 67.174.31.15
Port Forwarding Screen Shot:[Image: Screenshot_2019-07-19%20Advanced%20Port%...FINITY.png]

I am running four Garry's Mod servers via a Docker image that I created. The server ports 27015, 27005, and 27010 are all configured on the containers; TTT is just straight through, Prop Hunt has each port connected to the port + 1 (27016, 27006, 27011), etc. The actual SRCDS servers all think that they are running on default ports. I am aware that only TTT and Prop Hunt have their equivalent of port 27010 forwarded, I just stopped trying after it didn't work for Prop Hunt. I have tried running the heartbeat command via RCON.

I can connect to all of the servers just fine using both their internal and external IP addresses and ports, other people can connect to all of the servers just fine using the external IP address and ports, and all of the servers show up in the server history and favorite sections. Only the TTT server (which, by the way, is the only one actually accessible from the default ports) shows up on the public server list. No, it's not just me; no one else can find the other servers either. In fact, the TTT server was on the public server list even when I only set up port 27015 for each server. The other servers wouldn't show up in the history of favorites sections before I set up port 27005. Setting up port 27010 seems to have done absolutely nothing.

How do I make multiple servers running on one machine all appear on the public server list?
Reply
#2
You'll need to Port forward on your router in order to allow external connections. By default firewall's deny all incoming port access on your network for security reasons.

Go into your Windows CMD and type ipconfig then identify your LAN IP.
Log into your routers admin panel and go to the port forwarding page and port forward 27015-27015 on both TCP and UDP with a destination port set to your PC's IP.

If you've successfully port forwarded and still can't connect then you could be experiencing NAT Reflection problems which makes it so you can't connect externally to your own network and need a friend to test it for you.
Reply
#3
I don't know why you bothered posting on dead thread, especially with a copy-pasted reply assuming that I don't know how to forward ports. The original post here included port forwarding information, and mentioned that every server could be accessed externally.

While I'm here, though, I should explain what I eventually figured out for anyone else with this same issue: when SRCDS servers, or at least Garry's Mod servers, report their existence to the server list, they give the server list the port that they are running on in their options, and this is never translated to the external port. Since I was only separating the servers' ports by forwarding (internally, they were all default ports), all four servers reported the same exact IP and port to the server list, and the server list essentially registered all four servers as one. The fix is simply to run the servers with their internal ports matching their external ports, which is covered in the README for my Docker image (linked in original post).
Reply
#4
(11-11-2020, 05:13 AM)Phyremaster Wrote:  I don't know why you bothered posting on dead thread, especially with a copy-pasted reply assuming that I don't know how to forward ports. The original post here included port forwarding information, and mentioned that every server could be accessed externally.

While I'm here, though, I should explain what I eventually figured out for anyone else with this same issue: when SRCDS servers, or at least Garry's Mod servers, report their existence to the server list, they give the server list the port that they are running on in their options, and this is never translated to the external port. Since I was only separating the servers' ports by forwarding (internally, they were all default ports), all four servers reported the same exact IP and port to the server list, and the server list essentially registered all four servers as one. The fix is simply to run the servers with their internal ports matching their external ports, which is covered in the README for my Docker image (linked in original post).

You have a point but I think you should be nice then. Pool Decks
Reply
#5
Don't get too close bass guitar lessons
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)