SRCDS Steam group


FastDL Issue!
#1
Sad 
Dear community,

This is a problem that has bugged me the past few weeks in trying to set up a FastDL server for my tf2 servers. I have hosted an average of 6-7 tf2 servers daily on stock maps without any custom files for a few months now, previously having rented a game server online before moving to locally hosting.

Right now, I've got a working FastDL Server (ns1.ddlgaming.com/tf/). I know it's a nameserver, but I'm testing stuff while waiting for DNS propagation, but that should not ever affect anything.

This is the stuff in my server config file (cfgorange.cfg on my system, different cfg files for different SourceMod installs):

sv_downloadurl "http://ns1.ddlgaming.com/tf/"
sv_allowdownload 1
sv_allowupload 1
sv_maxfilesize 100

When I start up my server, and type sv_downloadurl in my console, it returns "sv_downloadurl" = "http:" (def:"")

So, something somehow is commenting the rest of the url by the double forward slash in http://. Please help me, I'm really stuck like I've never been. It's not my FastDL server problem, fastdl works normally when i manually change sv_downloadurl in my console.

I am running OS X EI Capitan.

Mark


Attached Files
.cfg   cfgorange.cfg (Size: 774 bytes / Downloads: 2)
Reply
#2
(02-26-2016, 05:32 AM)legendoniance Wrote:  Dear community,

This is a problem that has bugged me the past few weeks in trying to set up a FastDL server for my tf2 servers. I have hosted an average of 6-7 tf2 servers daily on stock maps without any custom files for a few months now, previously having rented a game server online before moving to locally hosting.

Right now, I've got a working FastDL Server (ns1.ddlgaming.com/tf/). I know it's a nameserver, but I'm testing stuff while waiting for DNS propagation, but that should not ever affect anything.

This is the stuff in my server config file (cfgorange.cfg on my system, different cfg files for different SourceMod installs):

sv_downloadurl "http://ns1.ddlgaming.com/tf/"
sv_allowdownload 1
sv_allowupload 1
sv_maxfilesize 100

When I start up my server, and type sv_downloadurl in my console, it returns "sv_downloadurl" = "http:" (def:"")

So, something somehow is commenting the rest of the url by the double forward slash in http://. Please help me, I'm really stuck like I've never been. It's not my FastDL server problem, fastdl works normally when i manually change sv_downloadurl in my console.

I am running OS X EI Capitan.

Mark


Hello,

I see your conf file look like this ->

//sv_downloadurl “http://ns1.ddlgaming.com/tf/“


remove " // "   in  sv_downloadurl  so that its, and fastdl  work 

and  but  same  fastdl.cfg   sv_downloadurl “http://ns1.ddlgaming.com/tf“
Reply
#3
If it says it's using the address given as a primary download location then the server is sending the URL to the client, and the client has recognized it as a valid address.

The problem must be in the code that handles downloading, it should check if the URL was given and use it if that's the case. From what i can tell the only reason a URL could be ignored is if the client doesn't mark the current map as using HTTP download. I'm not sure why this would happen though.
Reply
#4
Nothing in this world prepares you for that hearing aids cost
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)