SRCDS Steam group

SRCDS problem!
Hello! I've searched a ton on this error, but I can't seem to find any kind of fix that works for me.

The game server I'm trying to run is Garry's Mod, it worked fine until an update around the end of 2015.
Here's the error:

Console initialized.
ConVarRef mat_dxlevel doesn't point to an existing ConVar
Game.dll loaded for "Garry's Mod"
Initializing Steam libraries for Workshop..
steamengine.cpp <2369> : Assertion Failed: pBaseUser
Assert< Assertion Failed: pBaseUser >:steamengine.cpp:2369

Bat file:

@echo off
cd c:\srcds\orangebox
title srcds
start srcds.exe -console -game garrysmod +map gm_flatgrass +maxplayers 16 +gamemode sandbox +ip +clientport 27015
goto srcds

This bat file does work fine for servers prior to the update (though I can't fully join them, as I am kicked out due to them running an older version)

I appreciate help of any kind.
Have you tried saving in just on the face of your c drive then you can do "cd srcds" cause it will auto load the "C" drive then open up notepad or wordpad they both do the same thing and type into one: C:\srcds\srcds.exe -console -game cstrike +map de_dust2 +maxplayers 14 -autoupdate then save that as a .bat file so click Save as > Css Load.bat > Save then you can just clikc that link and cs should load. also checking boostrapper version will come up you have to let the files download by the way so when it starts saying things like 10%, 10.13%, 12.35% etc.
One single thread of gold tied me to you hearing aids cost

Forum Jump:

Users browsing this thread: 1 Guest(s)