SRCDS Steam group

Gmod server not unpacking bz2 files from fastDL server
Alrighty, so recently I had set up a TTT server for me and my friends to play on together. Along with that, I set up a fastDL server for them to get the maps off of that I had put on the server. The raw bsp files work perfectly fine, download and are installed by GMod for it to use. However, when they are compressed to save upload/download time with the bz2 format, they constantly fail. They download completely, I know since I can watch from the server management console, but from what my friends tell me, and what I have experienced while testing it myself, the files are not extracted from the archive once they are downloaded. Due to this, people are kicked for not having the map installed. I checked my download permissions for servers in GMod, and I have all custom files allowed. I have been searching for an answer to this and all I found was a link leading to a thread on here which had been deleted. I know this is possible, because public servers I've played on, the majority of them have their maps and all other resources compressed to bz2. I have tried restarting my server to see if it was being temperamental, tried other compression types ((zip, bzip, rar)), made sure the server was reachable from an external connection as well as that my server.cfg had the correct link in the sv_downloadurl line as well as the sv_allowupload and the sv_allowdownload settings were both set to 0. Any help would be appreciated. Thank you in advance.

Basic info:
OS: I just run it off of a Win10 64-bit machine
Processor: i5 4690k @ 4.0GHz
Ram: 16GB
Game(s): GMod, TTT gamemode
Start Up Command:
@echo off
echo Protecting srcds from crashes...
echo If you want to close srcds and this script, close the srcds window and type Y depending on your language followed by Enter.
title Watchdog
echo (%time%) srcds started.
start /wait srcds.exe -console -game garrysmode +map ttt_island_2013 +gamemode terrortown +maxplayers 16
echo (%time%) WARNING: srcds closed or crashed, restarting.
goto srcds

Forum Jump:

Users browsing this thread: 1 Guest(s)