SRCDS Steam group

SRCDS CSS Odd Error, cant fix, tried everything
Hello, so I have installed and setup a SRCDS CSS server 1000x times before.

So like usual I got SteamCMD, Logged in anonymously, typed "force_install_dir D:\SERVER\". Then I typed "App_update 232330 validate" like usual it downloaded all the server files. So now I go and create a .bat file where the "SRCDS.exe" is with the following line "srcds.exe -steam -console -game cstrike +map de_dust2 -maxplayers 16" just to test out the server.

This is where I get the error no matter what I did it would always says this after it tries to "Initializing Steam Libraries for secure Internet server". Right after it says that I get the error.

[Image: u0wp1m.jpg]

I did a test and took out +Map de_dust2 to see if it pops up the error without trying to connect to steam libraries. It didn't show the error, but as soon as I typed "Map cs_office" or any other map, it will Initialize steam libraries like usual but then imediately shows me the Assertion error.

Here are the things I have tried:

-Reinstalled SRCDS (Done this 4 times, a complete reinstall of all files, still shows same error."
-Restarted PC "Did this 3 times"
-Restarted Router "Did this Multiple times"
-Forwarded Ports "Ports are forwarded and Work correctly, started a listen server and people can connect to it."
-Looked up solutons on google "There is only 2 people who I have found that have this error from researching around Google, one from Facepunch Forums for a Garrysmod Server that didn't get solved, and one for css on steam forums that never got solved"

I am not sure what to do anymore. My only other Idea is to reinstall steam, but I really do not want to do that, so I am looking for a different solution. I have never had this error and it seems to be a problem with me not being able to connect to Steam Libraries or something like that.

If anyone could help me out here, it would be much appreciated. Big Grin

Forum Jump:

Users browsing this thread: 1 Guest(s)