SRCDS Steam group

Server Won't Update
Server OS: Windows 7 Professional 64 bit
Processor: Intel Core i7-2600 CPU @ 3.40 GHz
Game(s): Garry's Mod

Start Up Command: C:\newserver\srcds.exe -game garrysmod -port 27015 -authkey # +host_workshop_collection # +map ttt_67thway_v7_j_l +gamemode terrortown +maxplayers 32 -console
Server Folder: C:\newserver\

Installation Command: login anonymous force_install_dir c:\newserver\ app_update 4020 validate quit

Any help would be appreciated. My server won't update. It returns the error "The server you are trying to connect to is running an older version of the game", even after I have run many different updating scripts with SteamCMD.

I update it with SteamCMD, information on command line below
SteamCMD command line: login anonymous app_update 4020 validate quit

I have tried that script in SteamCMD and as a batch file with steamcmd.exe and the commandline.

For a week my server has not been updating because of this, recently today it said it updated in SteamCMD, but still returns the same error that the server is running an older version of the game.
Heres what happened today after entering the same command line from previous times I've tried to update, "Sucess! App '4020' fully installed."
I re-portforwarded, and restarted the server, it says this when I try to join still, "The server you are trying to connect to is running an older version of the game."

I am probably going to completely reinstall the entire server anyway because of this problem, as I've done in the past with this same exact problem, but I want to know what I'm doing wrong, and how to fix it, again any help would be greatly appreciated, as of no other places on the internet including Steam Discussions, Forums, and even the GMOD Wiki's Hosting a Dedicated Server page have not given me any help that has worked yet.
ok, I don't know much about that.. but the best I can give you is to do it separate.. it may be a pain in the butt, though it is the most ensuring way to not have any fuckups..

login anonymous

force_install_dir (directory)

app_update 4020

then wait

Forum Jump:

Users browsing this thread: 1 Guest(s)