SRCDS Steam group

Issues setup SourceTV relay
I've also posted this thread on Steam's official forums but since my issue is about srcds in specific I suppose I could get better help here. (Yes it's a copy paste from the other forum).

First of all I'd like to get it clear that I've searched the web for a whole night, did trials and errors in many ways and it still doesn't work. I've come here as last resort that someone could help me. Thanks for your attention. Onto the problem.

I've setup a source dedicated server for a game and it's working perfectly. I intended to enable SourceTV so that people could spectate the game. SourceTV is working and people are able to join the Master SourceTV to spectate.
tv_enable 1
tv_autorecord 0
tv_maxclients 1
tv_relayvoice 0
tv_delay 15
tv_port 27020
tv_maxrate 3500
tv_name Test TV
tv_title Test TV
tv_chattimelimit 2
tv_delaymapchange 1
tv_autoretry 1
However and as recommended from steam and many other people, it is advised to setup a relay to ease off work from the dedicated server. And so I tried, I made a shortcut to the srcds.exe with the following parameters:
-game GAMEUSED -console +tv_relay publicIP:27020
This is where the problem begins, the relay tries to connect to the supposed master relay but fails all attempts. I've tried changing to local IP instead of public IP but no difference, tried different ports, no difference. I've also tried adding the akward -ip parameter in a few ways and it just worsens the situation. The -port parameter and recursive +tv_port don't seem to help either. The information about relays on the web is quite scarce and the SourceTV wiki page isn't as helpful as you wish. I've found a Danish thread in here and google translator mostly managed to translate it successfully but it didn't help much.
Thus here I am asking for some more specialized help on the matter. If you need some general insight on the situation, this is the most helpful page I found.

Misc facts:
Yes, my ports are all forwarded.
For some reason tv_maxclients does nothing at all.
Steam's server browser, spectate tab, queries all servers but fails to connect to any of them. This seems a problem that affects all games and people can only spectate by manually connecting to the SourceTV server.

Forum Jump:

Users browsing this thread: 1 Guest(s)