SRCDS Steam group

[SOLVED]srcds.exe crashing
My srcds.exe is crashing, I wanted to know if you guys could help me out.

OS : Windows
Ver: 8.1 (problem before 8.1)
Game: Garry's Mod (x64)

My startup line :
Quote:@echo off
echo Protecting srcds from crashes...
echo If you want to close srcds and this script, close the srcds window and type Y depending on your language followed by Enter.
title Watchdog
echo (%time%) srcds started.
start /wait srcds.exe -console -game garrysmod +gamemode "zombiesurvival" +map gm_construct +maxplayers 32 -authkey ******************
+host_workshop_collection *****
echo (%time%) WARNING: srcds closed or crashed, restarting.
goto srcds

It then comes up with SRCDS has crashed or closed, restarting and then I get this error:
srcds.exe - Entry Point Not found
The procedure entry point
Z could not be located in the dynamic link library


EDIT : Close the thread, I fixed it. For anyone else having the problem follow these steps.
Delete the garrysmod/bin file.
Go into SteamCMD
Type these 2 commands
force_install_dir (Drive)SadLocation)
app_update (4020 for garrysmod) validate

Forum Jump:

Users browsing this thread: 1 Guest(s)