SRCDS Steam group

[TF2] Server crash after map change [fixed!]
See attached pastebin (URL below) for last ~240 lines of log, including a backtrace and whatnot.

My dedi (specs below) has been running servers steadily for months now. About 12-15 of them. No issues with any of them except for this one. It has been reinstalled many times, ran vanilla (ie no custom changes), all to no avail.

Here is what happens:
The server starts (default map cp_granary). Players join, someone uses rcon to change the map. Everything is fine up to this point. If, and only if, the map that was just changed to is cp_badlands, the server will either crash immediately, or it will disconnect half the players connected (they get a "steam auth ticket expired" message) and crash a moment later, or it will crash after roughly a minute of nothing noteworthy going on (players just randomly walking around). None of this happens on any other map. Only ever on cp_badlands. My players have joked that they played it too much and the server is tired of it. Sadly, that is the most reasonable explanation I've had so far..

The server is typically set up to be a match server. For those familiar, it runs the ETF2L 6v6 config. The crash also happens running vanilla with no modifications at all though.

Usually it would just crash "silently", with no useful information in console, but earlier today it suddenly spat out a message about glibc, something along the lines of "smallbin double linked list corrupted". I googled, and found some issues from years ago, where the suggested fix was to update glibc. I ran a system update and indeed, glibc needed an update. So that's what I did.

This made it even worse and made the console spit out what you can see in the attached pastebin (URL below).

I have run out of ideas. I haven't the faintest clue what I can do next to resolve this issue. Please help!

Dedi specs:
OS: CentOS 6.5 x64
CPU: Intel® Xeon® CPU E3-1245 V2 @ 3.40GHz (4 cores, 8 threads)
GAME: Team Fortress 2
CMD: ./srcds_run -game tf +sv_pure 2 -autoupdate +fps_max 0 -port 28001 +clientport 20001 +map cp_granary +maxplayers 4 -steam_dir /home/srcds_tf2 -steamcmd_script /home/srcds_tf2/tc1/update.txt
(this was the test run which resulted in the output in the attached pastebin, though anything else I've tried hasn't resulted in success either)
MODS: None.

I fixed this by changing the startup map to anything that is not cp_granary.

I still don't understand how or why that would cause crash after changing to cp_badlands though..

Forum Jump:

Users browsing this thread: 1 Guest(s)