SRCDS Steam group

No one can connect to my server
Ok, I'm trying to make a GMOD server and it isn't exactly working out. I've downloaded SteamCMD (Steampipe) and have installed the correct GMOD files following this guide

Now, I think the problem lies within the port forwarding (as usual) but i'm not quite sure. I've followed every step in that video guide and watched another one where he did the exact same thing. I've tried portforwarding the ports 27015 TCP and UDP, and port 27005 TCP and UDP. Since I have MTS i'm using a Pace router. But as you can tell, the port forwarding didn't work. I keep receiving the same error message "couldn't connect to the server after 4 retries" or something like that, if you've had this problem before then you know what i'm talking about.

I'm starting up the server using a .bat file using this watchdog.

@echo off
echo Protecting srcds from crashes...
echo If you want to close srcds and this script, close the srcds window and type Y depending on your language followed by Enter.
title Watchdog
echo (%time%) srcds started.
start /wait srcds.exe -console -game garrysmod -port 27015 +maxplayers 16 +map gm_construct +gamemode sandbox
echo (%time%) WARNING: srcds closed or crashed, restarting.
goto srcds

I've added the extra lines -port 27015 and +gamemode sandbox to see if that would fix the problem but it didn't. I've tried changing the port in the -port line hoping for a different port to work but to no avail.

To those who say to screw portforwarding and just use Hamachi I am refusing. I have a couple reasons why I can't and won't use Hamachi, but I won't get into that. All I ask is for some help on why no one can connect to my server.

Thank you to those who have helped me or have given information about the subject.


Forum Jump:

Users browsing this thread: 1 Guest(s)