SRCDS Steam group

TF2 Port Forwarding or conflict issue?
Alrighty, I am setting up a server on a Dell 850 (Pentium D 2.8GHz, 4GB of RAM, dedicated server machine). The server has run TF2 in the past, as well as L4D and Minecraft - often all at the same time.

I have a commercial internet connection with a static IP. The demark point has the internet coming into a SMCWBR14S Router, which I have set up with port forwarding using the Virtual Server option. The Dell server is directly connected to this router, whereas the rest of the household is connected to the router via a Dell switch.

I run the server using the following bat file:
232250server\srcds.exe -port 27016 -game tf -console +map ctf_2fort +maxplayers 32 +sv_lan 0

With the virtual server settings, and the server running on port 27016; the port tests as open using's test utility. I also have 27005 and 27020 forwarded in a similar manner, with both UDP and TCP for all virtual servers. Also of note, the Minecraft server is also running at the same time and is forwarded in a similar manner, and I have never had any issues with it.

Under some circumstances, the server will show up online, and friends will be able to connect. I can also connect remotely using my tethered cell phone internet connection. All is good, right? Wrong. If I try to change my gaming computer to my local internet, and connect to the same network the server is hosted on, it becomes visible on the LAN games list, however if I try to connect to it, it drops all the remotely connected players.

Also note, the server is authenticated as a registered server, and logs into Steam and VAC okay, every time.

I have tried port filtering, I have tried DMZ, I have tried various arrangements of firewall settings, or disabling the firewall all together. But the thing that seems to work most often is the virtual server settings, however I still end up with this issue. I imagine it is a port conflict between the game server and my local gaming computer? But I haven't been able to figure it out.
Well I am glad I am not the only one who doesn't have an answer to this problem... lol

Forum Jump:

Users browsing this thread: 1 Guest(s)