SRCDS Steam group

Map Not Downloading (FastDL)
Ok, my server is working fine but when people join without the map it begins to download the map then it will just stop randomly and then give the Missing Map error.

I have been looking for hours on a way to fix this, other files will be downloaded fine. The map in question is gm_construct_flatgrass_v6-2 it is on the webserver in a .bz2. The file can be downloaded fine in a browser.

I have tried it on a basic local http server and it will download from that, possibly a timeout thing?

when downloading it will do about 20-30Mb of the file (looking at wireshark) then just stop and try the non-bzip2, this then fails 'coz thats not on the webserver.

Here are the relevant settings in my server.cfg:
"sv_downloadurl"        ""
"sv_allowdownload"    "1"
"sv_allowupload"        "1"
"net_maxfilesize"        "64"

I'm stumped, any suggestions welcome!
I've tried connecting to your sv_downloadurl but it leads to nowhere. That may be your problem. You've stated that it is a local http server so a few things i can suggest are to double check that you've properly set up the server and to input the IP of the http server as the sv_downloadurl.

Forum Jump:

Users browsing this thread: 1 Guest(s)