SRCDS Steam group

[SOLVED] L4D2 Server Not Prompting For Password
I was able to get my L4D2 Server on-line, but for the life of me I cannot figure out how to get it to prompt for a password.

Here is my server.cfg file (changed the actual password to blah blah blah):

hostname "Tronyx's Left 4 Dead 2 Server" // Hostname for server.
rcon_password "blah blah blah" // remote console password.
sv_password "blah blah blah" // Password protects server
sv_gametypes "versus,survival,coop,realism,teamversus,teamscavenge" // Allowable game types of the server

// Server Cvars
sv_alltalk 0 // Players can hear all other players' voice communication, no team restrictions
sv_clearhinthistory 0 // Clear memory of server side hints displayed to the player.
sv_consistency 1 // Whether the server enforces file consistency for critical files
sv_contact "<your email here>" // Contact email for server sysop
sv_pausable 0 //Is the server pausable.

// Lan or internet play, Server region cvars
sv_lan 0 // Server is a lan server ( no heartbeat, no authentication, no non-class C addresses )

// eastcoast
sv_region 0

// Server Logging
sv_log_onefile 0 // Log server information to only one file.
sv_logbans 1 // Log server bans in the server logs.
sv_logecho 1 // Echo log information to the console.
sv_logfile 1 // Log server information in the log file.
sv_logflush 1 // Flush the log file to disk on each write (slow).
sv_logsdir "logs" // Folder in the game directory where server logs will be stored.

// bandwidth rates/settings
sv_minrate 20000 // Min bandwidth rate allowed on server, 0 == unlimited
sv_maxrate 30000 // Max bandwidth rate allowed on server, 0 == unlimited
sv_mincmdrate 10 // This sets the minimum value for cl_cmdrate. 0 == unlimited
sv_maxcmdrate 33 // (If sv_mincmdrate is > 0), this sets the maximum value for cl_cmdrate

//Difficulty Settings
z_difficulty Normal // Difficulty of the current game (Easy, Normal, Hard, Impossible)

// Voice Comm
sv_voiceenable "1"

// Ban stuff
writeid // Writes a list of permanently-banned user IDs to banned_user.cfg.
writeip // Save the ban list to banned_ip.cfg.
exec banned_user.cfg // Execute the banned_user list
exec banned_ip.cfg // Execute the banned_ip list

Here is what I use to start the Server:
echo "Starting L4D2 Server"
sleep 1
screen -A -m -d -S l4d2-server ./left4dead2/srcds_run -console -game left4dead2 +sv_password "blah" -secure -maxplayers 8 -autoupdate -port 27016 +exec /left4dead2/cfg/server.cfg

I connect to the Server by launching L4D2, opening the console and then using the connect command.

Anyone have any suggestions?


Ok, so it looks like you cannot password a L4D2 Server. The only solution is that you launch L4D2 in Steam, open a console and enter the following:

mm_dedicated_force_servers XXX.XXX.XXX.XXX:port

Then you can create a new lobby, invite friends and then start the game. Simply replace the XXX.XXX.XXX.XXX:port with the IP of your Server and it's port. Guess I just have to give people that command and the IP of my Server so they can play without me as I don't want the Server to be public all the time.

Marking as solved for posterity.


Forum Jump:

Users browsing this thread: 1 Guest(s)