SRCDS Steam group

gmod support dedicated hosting - connection failed after 4 retires

it shows on lan, friends cant connect (same problem as me):

server.cfg (bit of a mess):

// Server.cfg Executes on maploads.
// For Convars like sv_cheats 1 = on 0 = off.

// main server settings.
hostname "Underground Resistance UNDER CONSTRUCTION"
rcon_password "xxxxxxxxxx"
hostport 27016
clientport 27005
tv_port 27020
maxplayers 8
gamemode "darkrp"
sv_password ""
sv_region 2
sv_timeout 65
sv_lan 0
decalfrequency 10
sv_cheats 0
exec banned_user.cfg
exec banned_ip.cfg

// Logging, turn this off if you don’t like the logging in the console (L <date> then some other stuff), logs are in garrysmod/logs
log 1
sv_logbans 1
sv_logecho 0
sv_logfile 1
sv_log_onefile 0
sv_stats 1
sv_noclipspeed 5
sv_noclipaccelerate 5

// Rates…
sv_allowdownload 1
sv_allowupload 1
net_maxfilesize 1000
sv_maxcmdrate 33
sv_maxupdaterate 100
sv_maxrate 6800
sv_minrate 0
sv_minupdaterate 20
tickrate 66

// max and limts.
sbox_godmode 0
sbox_noclip 0
sbox_maxprops 60
sbox_maxragdolls 0
sbox_maxnpcs 0
sbox_maxballoons 0
sbox_maxeffects 0
sbox_maxdynamite 0
sbox_maxlamps 0
sbox_maxthrusters 0
sbox_maxwheels 0
sbox_maxhoverballs 0
sbox_maxvehicles 0
sbox_maxbuttons 20
sbox_maxsents 0
sbox_maxemitters 0
sbox_maxspawners 0
sbox_maxturrets 0

// "sbox_allownpcs" "0" // Allow NPCs in DarkRP put it on
// disabled = 0 \\
// "sbox_maxprops" "15" // Don't make this too much if you use a // good map as rp_downtown_v2 \\
// "sbox_maxragdolls" "0" // Unnecessary on DarkRP.. \\
// "sbox_maxnpcs" "0" // It's disabled so make it 0 \\
// "sbox_maxballoons" "2" // Balloons Very Happy \\
// "sbox_maxeffects" "0" // Put this off or people will make the // skybox weird and dark... \\
// "sbox_maxdynamite" "0" // It's RP not Oh snap trap, land \\
// "sbox_maxlamps" "0" // Lamps, this will make the server lagg // "sbox_maxthrusters" "5" // Why would we need thrusters
// anyway? \\
// "sbox_maxwheels" "4" // Idk if roleplayers are bored... \\
// "sbox_maxhoverballs" "0" // This will only be prop lifting \\
// "sbox_maxvehicles" "0" // You can spawn vechicles not
// recommended on small maps \\
// "sbox_maxbuttons" "5" // Just make it enough, people want to // have buttons or its prop block \\
// "sbox_playergod" "0" // Same as godmode 1 to enable 0 to
// disable \\
// "sbox_noclip" "1" // Everyone will be able to noclip also
// guests. \\
// "sbox_godmode" "0" // Godmode; no one will be able to die in // your server. \\
// "sbox_plpldamage" "0" // PeopleDamage; 1 = Disabled 0 =
// Damage; deathmatching \\

// DarkRP convars

//Voice Chat
sv_voiceenable 1
sv_alltalk 1

//Fall Damage, 1 for realistic, 0 for 10 hp
mp_falldamage 1


and my start up line:

@echo off
echo Protecting srcds from crashes…
echo If you want to close srcds and this script, close the srcds window and type Y followed by Enter.
title Watchdog
echo (%time%) srcds started.
start /wait orangebox\srcds.exe -console -game garrysmodbeta +exec server.cfg +hostport 27016 +map rp_downtown_v4c_v2 +maxplayers 8 -autoupdate +ip
echo (%time%) WARNING: Underground-resistance server crashed, restarting.
goto srcds

my specs:
Processor: Intel ® Core ™ i5-3470 CU @ 3.20 GHz 3.20 GHz
8.00 GB ram.
64-bit windows 7 OS.

console gets alot of errors from Darkrp file (yes its updated for this github) but server shows on lan so im guessing darkrp not messing with it.

connection fails after 4 retries for me and friends connecting using console: connect

tried IP given by console after "Connection to Steam Servers successful." ("public IP is") and tried one that shows on LAN for me on both normal and legacy browsers (

btw yes im back and i seem to got further than last time xD
Hub Firewall Disabled.
DMZ enabled.
Allowed through software firewall.


[Image: 20pdeog.png]
bump... Sad
still checking back every once and a while, nothing new? Sad
I wish I could help, but I have the same problem. It's such an annoying problem, and even worse when everyone on these forums just ignores each other. This forum is dead. Good luck solving it, please message me if you find a way around it.
ok, will do, checking now Smile
If you can't host even after you enable DMZ you're kind of screwed. You might need to go out and pick up a good router if that's the case. I had that problem with one of my old routers, it was a cheap $20 one I got from a staples. My new one is a nice $120 router that allows up to a 1 gbit connection and I'm able to host plenty with my 20mbit upload.

Just for a quick check, usually when you enable DMZ you have to specify the computer you're enabling it for. The past routers I've been through always ask me for the IPv4 address of the computer, for example; = Computer 1, = Computer 2

If you want to find out your IPv4 address then open your command prompt and type in "ipconfig", without the quotes.

Sorry for the inactivity though, I don't tend to get on this forum much anymore. The owners haven't been on since August.
Get free clan themes & templates @ Gamer Templates
Get free fast download @ DropBox
np, didnt wait long in my eyes Smile

anyways, its the standard BT home hub 3 shait, the stuff they give for free and dont care if they get it back -.-'
Hi there, SystemsOverload!

It seems like you have totally messed up your ports. You only need 1 port and that is: 27015 TCP and UDP for 1 server.
From 27015 To 27015 on IPv4
I got several Counter-Strike Source server, so I have opened 27015 to 27020, as shown in the blue square in the picture here:
Name-----------------Activated--Status--Protocol-From--To----Redrafting---IPv4 Address
[Image: NET-39.png]

So simpel is it. And the IP is just my IPv4 from CMD>ipconfig>IPv4 Address
For more help, just hit me:
Steam: bilbodog
Skype: bilbodog2

And don't forget to +rep [Image: NET-5.png]
- Best Regards bilbodog (Casper Thomsen)

Forum Jump:

Users browsing this thread: 1 Guest(s)